Jump to content
  • 0

How to work with one USB cable in zedboard?




I tried HelloWorld example in Vitis and Vivado 2019.2 and this worked well until programming FPGA. 

Because I have only one USB cable to connect into zedboard PROG port or UART port, I ran a HelloWorld program with "RunAs -> Launch on Hardware(System Project Debug)" with connecting cable to PROG port and reconnected to UART port to receive outputs from zedboard.

However, I got weird results(e.g. there is no outputs or there is outputs but garbled).

After that, I borrowed a cable from my friend and also connected it to zedboard, and I rerun program and got appropriate outputs.

My question is whether I must have two cables to connect two ports when programming FPGA and run program by jtag.
If not, please tell me how to do that.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Hi @SoyaOhnishi

In case of petalinux you may not need two cables since fsbl or u-boot can load the bitstream into fpga ("programiming") usually done over USB-JTAG (J17). 
To include bitststream in boot.bin use petalinux-package command see ug1144 for your version of petalinux.
You only need to connect to UART over USB (J14) to see linux console. 

However if you have a standalone application you need two cables one for USB-JTAG to debug or load bitstream (J17) and one to communicate with your application over UART1 (J14).

If boot your application from SD and load it using a fsbl that will also load the bitstream in fpga the USB-JTAG cable is no longer needed.

UART0 in ZYNQ is not assigned. you can use EMIO and have it mapped to a PMOD connector if you need an extra.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...