Jump to content
Responses from Digilent staff may be delayed during the USA Thanksgiving holiday ×
  • 0

U-boot error on kernel load


mihai5

Question

Hi,

  I try to use petalinux 2017.2 to create a linux kernel for running on zedboard. I copied all the files from <petalinux_project_created>/images/linux$ and also <petalinux_project_created>/pre-built/linux/images$ into a fat32 partion on sdcard. At power on, I expected to get automatically into bootloader and just to run the command "run bootcmd" to get into linux OS, but it doesn't.

   I dowloded the bitstream and the u-boot.elf to get there. In this way i get into the u-boot but i get a strange error ...

Zynq> run bootcmd
Device: sdhci@e0100000
Manufacturer ID: 74
OEM: 4a60
Name: USD   
Tran Speed: 50000000
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 7.5 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
** Invalid partition 1 **

I have 2 partions on my sdcard (BOOT - 450MB - FAT32 and ROOTFS-7GB-ext4). Did anyone meet this error?

Thanks,

Mihai

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Hi @jpeyron

         Meanwhile i solved my problem. The problem was that through a windows machine i tried to partition my sdcard into 2 partitions (boot + rootfs), but it partitioned into 4 partitions, from which 2 sub partitions(my desired partitions).
Trying to boot from the first partition which was a ext4 type rised this error.

Thanks,

Mihai

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...