Jump to content
  • 0

Digilent Wave Forms and Analog Discovery 2, Wavegen problem, don't stop


latot
 Share

Question

Hi all, I found a problem with WaveForms, actually I have connected WG and the Scope with a resistor in the middle, 1V DC, I start the WG and the Scope, all seems right in the Scope, but...., when I stop the WG, I notices the Scope still shows corrent, it didn't stop!, but..., it stop if I close the tab of the WG in WaveForms....

Thx!

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @latot,

I'm not certain what you are describing.

Are you saying that the Scope is still capturing the same waveform that was being generated by the Wavegen (which you stopped) or that the Scope is still acquiring data in general?

If the Scope is still running and you want it to stop at the same time as the Wavegen, you would need to click the "Stop All" button in the upper right of the application.

Alternatively, you can set up a normal trigger condition on the Scope so that it only captures data when that condition is met (such as looking for a rising condition above 0.5 V when the Wavegen is creating a -1 V to +1 V sine wave). If you leave the rising condition at 0 V (which is the default offset voltage which is what the Wavegen idles at when not running), then the Scope will continue to capture data as there is some oscillations that will have the output get above 0 V.

Let me know if you have any questions.

Thanks,
JColvin

Link to comment
Share on other sites

  • 0

Hi @latot

Disable, uncheck the Enable to have 0V output.

The Idle output (Enabled and Stopped or during Wait) of Wavegen is by default the Offset, see pic1
You have option to make the Idle Initial but there is no option for 0V since the offset has a significant settle time, see pic2

image.png

image.png

Link to comment
Share on other sites

  • 0

Hi,

On 1/25/2023 at 8:09 PM, JColvin said:

Are you saying that the Scope is still capturing the same waveform that was being generated by the Wavegen (which you stopped) or that the Scope is still acquiring data in general?

The Scope is still capturing the same waveform that was being generated by the Wavegen.

On 1/26/2023 at 5:39 AM, attila said:

Disable, uncheck the Enable to have 0V output.

 

Mmmm, is not the same, stop the WG to uncheck "Enable"?

On 1/26/2023 at 5:39 AM, attila said:

You have option to make the Idle Initial but there is no option for 0V since the offset has a significant settle time, see pic2

If I close the tab, it stop in the moment, well If I put more zoom and samples probably I'll be able too see some time for it to stop. Is a little weird if it need so much time to stop the signal.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...