Jump to content

NETFPGA-SUME: DONE LED (LD4) not turning on / USB-JTAG port not responding

Recommended Posts

Hello everyone!


I just install a NetFPGA-SUME and I am not sure if it is ok.

I followed the getting started guide in https://github.com/NetFPGA/NetFPGA-SUME-public/wiki/Getting-Started-Guide, however, something went wrong apparently...


In the Section IV: NetFPGA-SUME First Power Up, I followed the steps, but, after turning on the power switch (SW1)  it says I should see Power LED (LD10) and DONE LED (LD4) turn on immediately, however I only see the Power LED (LD10) on... in red. The DONE LED is off.

In the next step...

When I connect USB to my computer I can see a new USB serial device attached

[   13.194737] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB1

However, when I try to connect, terminal does not respond (I'm using putty to connect /dev/ttyUSB1).

Any clue about what is happening? I tried it with the card connect to my server PCI and also stand alone. Also connecting 2x4 and 2x3 PCI express auxiliary power connectors.


Thank you in advaned!

Link to comment
Share on other sites

Sorry for the delay. 

First things first, please double check that JP1 is not shorted. It is labeled M0 and can be found by the micro USB port. If that jumper is shorted, you need to unshort it and that is your problem. Otherwise, I've got some more suggestions.

Is your NetFPGA-SUME new or has it been used before? It is possible to erase the bitstream stored in flash using the dsumecfg utility, and that would explain why DONE doesn't go high. Another possibility is that the CPLD has been accidentally reprogrammed over JTAG, but that is less likely. Both of these issues are solvable.

As for the UART issue, that is expected if the FPGA is not programmed. 

Please try running through this guide: https://github.com/NetFPGA/NetFPGA-SUME-public/wiki/Reference-Operating-System-Setup-Guide. Once you complete it, please run the following command at the terminal:

dsumecfg write -d NetSUME -f production_test.bit -s 0 -verify

You will need to place the attached bitfile in your current working directory.

Let me know what the terminal reports from the above command and we can go from there.


Link to comment
Share on other sites

  • 7 months later...

Dear Sbobrowicz,

I ran the command you mentioned and it seems that everything was ok. The messages I got were:

Configuring FPGA...
FPGA configuration succeeded.
Erasing Flash: 100%
Writing Flash: 100%
Verifying Flash: 100%
Configuration Successfully Written to Flash

Now LED LD4 is in orange color. But the LD10 is still in red.

Is it ok?


Fábio (Regis' Advisor)

Link to comment
Share on other sites

Ok, thanks.

One more doubt: I am running the acceptance test, specifically I am running each test individually. The first one I used make ddr3A. Everything seems to be ok, but as you can see in the picture attached it stops on 60%. How much time does it need to finish this test?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...