Jump to content
  • 0

MCC 128 can not open device

Paul Chang


Dear Sir,

I have an MCC 128 device mounted on a raspberry pi 4B.(OS is Raspbian GNU/Linux 10)

RPI configuration :SPI and I2C are enabled.

It can not open device 


It can not update firmware also.




I also ref below link and change another charger .




It still can not solve this problem. Do you have other suggesion ?


Best Regards,


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello @Paul Chang.

Has the MCC 128 worked previously or is this a new board?

Is your RPi 4B module new or has it worked previously with HATs?

Please retest using a power supply adapter (+5V and 3A) to the RPi 4B instead of a battery pack.

Did you install the current MCC DAQ HAT Library version

Any success using the MCC 128 after executing the following?

sudo apt full-upgrade

sudo reboot

sudo daqhats_read_eeproms



Is the MCC 128 the only HAT mounted on the RPi 4B?  If it is, then you may have a defective MCC 128 board or perhaps problem with your RPi, specifically the SPI port.  Do you have another RPi module or MCC 128 board to test?  If not and retesting with a power supply adapter did not resolve your issue, then contact your vendor for a replacement, if the MCC 128 is less than a year old.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...