Jump to content
  • 0

MCC 128 unexpected device ID

Taimur Ishtiaq


I have an MCC128 device mounted on a raspberry pi 4 model B.

I followed the steps as listed on the github to install daqhats at "https://github.com/mccdaq/daqhats" and I can't seem to get it to work.

When I try to list boards, it says can't open device. (screenshot below)
When I try to update firmware, it says device cannot be confirmed as mcc128 and unexpected device ID 0xFF. 

I tried unmounting, remounting, restarting, reinstalling, not sure what the issue could be.

Thank you.



Edited by Taimur Ishtiaq
Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Run sudo daqhats_read_eeproms, then use the MCC DAQ HAT MANAGER to test the board. Do you have anything else, like a display, attached to the Raspberry PI?

MCC DAQ HAT Manager can be found under the Raspberry->Accessories 

Link to comment
Share on other sites

  • 0

Hi. Thank you very much for your assistance.

I ran sudo daqhats_read_eeproms, it shows up and here's the output.


It shows up in the MCC DAQ HAT MANAGER, here's the output


However, it fails to open or test the device and all options are greyed out. Clicking open button does nothing.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...