Jump to content
  • 0

Genesys zu-5ev petalinux booting issue




I am using the Genesys zu-5ev board and trying to build a petalinux image. If I apply the workflow explained below, the error LED on the board is on just after powering the board and no boot screen is visible via the serial port.

I am using Vivado 2023.2 and petalinux 2023.2 (same error occurs also on version 2022.1)

The following worklflow was applied:

- load the latest board file (version C0)

- create new Vivado project using the board file

- in the Vivado project, I create the block design and just add the zynq ps without modifying the IP

- I connect the pl_clk0 output with the axi clk input

- validate disign, create HDL wrapper, generate Bitstream and export hardware

- on the petalinux workflow i create a petalinux project with zynqMP template and add the .xsa file

- petalinux-config without any modifications, petalinux-build and petalinux-package

- flash sd-card via dd

I tried the same workflow with Vivado and petalinux version 2022.1 with the same result. I red something about fsbl patch but I am not sure which version of petalinux has to be patched. Any help would be great, thanks.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @Chr,

Add a debug to your FSBL to make sure the boot process is actually starting.
In file: project-spec/meta-user/recipes-bsp/embeddedsw/fsbl-firmware_%.bbappend
Add line


Build and repackage BOOT.BIN than try again see if the fsbl is loading.

FSBL is the first program that prints to serial console so make sure the port is opened early on.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...