Jump to content
  • 0

Data Translation DT9802 Unknown Device



I have been using a DT9802 for a while, but recently (it seems to be correlated with a Windows update), I'm unable to communicate with the device. I'm not sure if it's broken, or if it's an unresolved driver issue. When I re-install the DTOpenLayers software (Without the device connected), I still get an Unknown Device in the device manager, indicating the drivers are not found/cannot be installed. I've tried searching manually for the drivers and selecting the folder within C:\Program Files (x86)\Data Translation\DeviceDrivers to no avail. I've additionally tried installing the software on a different computer that hasn't ever been connected to the and connecting the device to the computer without success. Finally, I've had our IT folks come over (this is a company-managed computer) and sign in with their administrative log-ins, turning off firewalls, and trying to connect to the device, again without success.

I'm wondering if my device just got fried somehow, and if there's a good way to determine if the issue is the device or my driver installation process. Thanks for any help provided.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0


If it had been working and now it isn't, there's a good chance it's broken. You could try to unplug the device first, then download and install the required software from the Omni CD. https://mcc.download.ni.com/#downloads/DTSoftware/Omni-CD/. After completing this, plug it back in and try the QuickDAQ software. If it fails, let me know the serial number, and I'll see if it can be repaired.

Best regards,

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...