Jump to content
  • 0

E-1608 firmware update failed, device unreachable now


BenjaminW

Question

Hello,

I tried to perform a firmware update on a MCC E-1608 device but unfortunately it failed. The device is not more reachable now.

 

There was the firmware version 1.01 installed and I tried to update to 1.03.

For performing the firmware update I used InstaCal Version 6.73.

 

During the update process InstaCal showed the message similarly “Device could not be detected in boot loader mode”.

After that I waited about 15 minutes without any progress. So I closed InstaCal and repowered E-1608.

 

Since that E-1608 powers up only with both LEDs (power and activity) permanently blinking synchronously. The E-1608 is permanently not more reachable, neither via InstaCal nor via Windows ping command. Also resetting default network settings by pressing Factory reset button during powering on is without any impact.

 

What could I do to make my E-1608 working again?

Is there a possibility to flash the E-1608.hex file using a Pickit 3 programming tool?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Here are the steps to reload the firmware:

1.         Download the device’s new .hex file from https://www.mccdaq.com/firmware.aspx, and place it in the ..\Measurement Computing\DAQ\FirmwareImages folder.

2.         With power removed, remove the four screws holding the case together to expose the circuit board. 

3.         Locate the six-pin header connector and short the two center pins.

4.         Apply power and run InstaCal

5.         The device name will be something like E-1608-BOOT-LOADER

6.         Perform the firmware update.

7.         Remove the power and the heard jumper; afterward, the device should return to normal operation.

 

Link to comment
Share on other sites

  • 0

Thank you for your instructions, JRys.

Unfortunately it didn't work. I cannot establish an ENET connection from InstaCal to the E-1608 device. InstCal don't detect the device. Also ping is without response.
What IP address is used by the bootloader by default?

Link to comment
Share on other sites

  • 0

My problem was solved with the help of MCC Support Germany! I got the tip to access the E-1608 IP address using a DHCP router.
I configured the DHCP router to use that net the E-1608 was in before the firmware update failed.
After connecting the E-1608 and my PC to the DHCP router my E-1608 was detected by InstaCal automatically as E-1608-BOOT.
The Firmware-Update worked afterwards as you described. My E-1608 is alive again and works normally with firmware version 1.03.

Thank you for your help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...