Jump to content
  • 0

Trouble installing ULx for LabVIEW 2021


mPiszak
 Share

Question

Hello to all,

I recently upgraded LabVIEW from 2020 to 2021 (21.0.1f1) and no longer can install MCC driver for LabVIEW. I downloaded latest MCC DAQ software bundle form the website. InstaCal and Universal Library installations go without any problem, but when it gets to install ULx for LabVIEW I get "LabVIEW 2010 or later is required for this package". On the website description of ULx for LabVIEW it is stated that the support goes from LabVIEW 2010 to 2021 so I don't understand the issue.

Can anybody help with this problem?

Best regards,

Marcel

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hello,

 

I am running LV 21.0.1 32 bits and I tried to install the package listed previously but with no result. Instacal in installed, the board is recognized, but neither Ulx help nor Ulx library appears in Labview menus.

Is there a solution ? A rollback to LV2020 is, sadly, out of question.

 

Thanks !

Link to comment
Share on other sites

  • 0

Hi Marcel,

See if you have a ULx folder in \National Instruments\Shared\ and in \National Instruments\LabVIEW 2021\Examples\. If the ULx folders are present the support is install. However, the menu file somehow vanished. The following KB article addresses this topic:

https://kb.mccdaq.com/KnowledgebaseArticle50382.aspx

The help file should be in C:\Program Files (x86)\National Instruments\Shared\ULx. If it is there, you could make your own shortcut.

Best regards,

John

Link to comment
Share on other sites

  • 0

Hello, I am running LabVIEW 2022 Q3 32 bit (22.3f0) I am experiencing the same problem as Marcel above with this new software version. On the ULx install step I get a message that "LabVIEW 2010 or later is required for this package". and the install gets interrupted before the software can be installed.

I have instaCal 6.73 installed and it recognized my device.

I attempted the solution suggested by John using the files in the ULxForLV.zip in LabVIEW2021_ULx downloads folder. When I ran the software provided in this folder I got the same message and installation was unsuccessful. 

Can anybody help with this problem?

Kind regards,

Will
 

Link to comment
Share on other sites

  • 0

Hey Will,

The ULx for LabVIEW Installer program does not yet support LabVIEW 2022. Only versions from 2010 to 2021. I will check as to when we plan to release LabVIEW 2022 support and will update this thread.

I'm sorry for the bad news,

John

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...