Jump to content

No response received on android hotspot

Recommended Posts

I'd like to use my OpenScope MZ on the go, so I was hoping I could have it connect to the hotspot I can create with my Android phone. It seems to be connected (solid blue led, blinking yellow led), it's also connected to my computer through usb where I can see it's ip address, but when I try to add the device on the WaveForms Live Android app or on waveformslive.com I get the "No response received" error. Even a ping to the ip fails.

I also confirmed the ip using the Hotspot Manager app on Android. I tried running through the WiFi setup again. I have up to date firmware (1.296.0). When I try the same on my regular home wifi network I can add and access the device.

Could I be doing something wrong here? Have you guys connected the OpenScope MZ to a Android hotspot?

Link to comment
Share on other sites


I think this is caused by a 'feature' of Android.  If your android phone is connected to two networks (a wifi network and a cellular data network) it seems to route all traffic through the one it deems the primary network adapter.  In my experience if one connection has internet access and the other doesn't the one with internet access becomes the primary network adapter.

In your case I assume you're connected to cell data (which has internet access).  From Android's perspective the wifi hotspot does not have internet access so Android is going to prefer the cell connection for all requests from the Android device.  This means that when you type the IP address of the OpenScope into WaveForms live android is going to go looking for it on the cellular network adapter and not the wifi network adapter.

I was surprised to learn that Andriod worked this way.

Try turning off cell data on your phone and then connecting to the OpenScope by IP address.  I tested this and it worked on my Moto G5 with Android 7.


Link to comment
Share on other sites

Thanks for trying this!


Try turning off cell data on your phone and then connecting to the OpenScope by IP address. 

Just tried this. Looks like the order I do things matters, when starting the hotspot and then disabling cellular data it doesn't work, but after restarting the hotspot it works!

It's quite a workaround, but at least it works.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...