Jump to content

Cmod A7 35T Vivado 2016.4 There is no current hw_target


Recommended Posts

Hi All,

I have the Cmod A7 35T, downloaded Vivado 2016.4, and I am on Windows 7 OS.  When I go into the hardware manager I can connect to the localhost (connect_hw_server) but when I attempt open_hw_target I get the following error in the Tcl Console: Error: [Labtoolstcl 44-469] There is no hw_target.

I've checked to make sure that my device drivers are up to date.  I'm just using a standard micro-usb cable that I had in my house.  According to Digilent, I don't need a special USB cable.

Any help or advice you could provide would be extremely appreciated. 


Edit: I've tried a few more things and want to provide some more information.  

  1. I've uninstalled and reinstalled Vivado. When I reinstalled it I made sure that "Install Cable Drivers" was selected.
  2. I went into Device Manager and made sure my drivers were up to date.  There was even an iteration where I uninstalled the drivers and manually installed them from the command line.
  3. When I plug in my Cmod A7, the out of box demo is already loaded on the board.  I can click button 0 and the LEDs "count" as expected.  I have Tera Term and I can click button 2.  Tera Term then displays the Memory Test Application as expected.
Link to comment
Share on other sites


Yes, you can use a standard USB cable.  However, USB cables do break over time and with use.  Since they have four wires within them (power, ground, and two data), the data wires may have broken.  If you've only ever used the cable for charging, you might not know if the data wires work.  Can you tell me if this cable works in an application requiring data transmission?

Another common problem is that your laptop (or desktop) doesn't provide enough power to the USB port.  Sometimes a powered USB hub can help..

See here for a list of common problems if neither of these helps, and please write back if you find the problem as well as if you are still struggling.


Link to comment
Share on other sites

@D@n, thank you for your response!

- I was able to download pictures from my phone to my computer and put pictures on my phone from my computer using the USB cable.

- I used a powered USB hub and Vivado still did not see the board.

- I downloaded the device drivers and still do not see the board.


Device Manager.PNG

I went through your website and the forums that you reference.  Unfortunately, none of those answers have been the same problem that I am seeing.  I'm not sure what I'm doing wrong.

Link to comment
Share on other sites

@jpeyron I downloaded Adept 2 and I can now see the Artix-7 in Vivado.  So it works now.  When I downloaded the drivers originally I either must have done something wrong or not downloaded the correct ones.  To answer your question, I see the exact same picture you see above when I open Adept.  Thank you very much for your help!

@D@n I believe it was the device drivers.  After fulling installing Adept I was able to see the chip in Vivado.  I'm not sure how I was installing the drivers incorrectly originally.  Thank you again for your help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...