Jump to content
  • 0

Zybo linux_bd Petalinux




I've built a custom design by adding some extra IPs to the diligent reference design for Petalinux:


Then I've created a new Petalinux project importing the hardware specification from the custom design. To include the software support for Digilent's IPs I've configured Petalinux in the same way as the reference bsp (including uboot and kernel sources from Digilent's git repo).


Then, in order to build petalinux, I need to add the CONFIG_SYS_MALLOC_F=y flag to the uboot configuration file. After this, the build process succeeded. However, if I try to boot the image from the SD card the "done" LD10 led start blinking and the boot fail.

What I'm doing wrong?



Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Hi @Twoism_,

I have reached out to our embedded Linux engineer who will be able to give the best response to your question. They should be able to respond to you questions in the next week. I am sorry about any inconvenience this might cause you. 

thank you for your patience,


Link to comment
Share on other sites

Hi @jpeyron,

thank you for your answer. To double check, I repeated the process starting again from the linux_bd design but, this time, leaving the design untouched and I got the same error (blinking DONE LED). I suspect that, for some reason, the FSBL fail to configure the PL.

Link to comment
Share on other sites

In order to find a workaround, I've tried to configure the project to source only the kernel from the Digilent repo, leaving uboot to the default "u-boot-plnx". With those settings, the build succeeds and the board is able to boot. However, the HDMI output does not work (no /dev/fb0).

I've enabled the "Digilent VGA/HDMI DRM Encoder Driver" support from the kernel config, expanded the CMA pool, and copied the device tree "manual" settings from the "system-top.dts" file of the BSP project. Yet, I'm still missing the video output.

Looking for a simple design I've done the same process starting from the hdmi_out design:


Again, with no results...

Link to comment
Share on other sites

The blinking DONE LED is concerning... That means the FPGA is being programmed, then immediately reset. This can happen when powering from USB due to the ZYBO trying to draw too much current. How are you powering the ZYBO? What do you see at the UART terminal when that occurs?

Please also provide the output of dmesg when you use your workaround.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...