Jump to content
  • 0

DT9857E Sync Bus Termination Resistor - No Data Acquisition in QuickDAQ possible when enabled


Christian Pichler

Question

When using multiple DT9857E modules with the Ain sync bus, the manual states on page 39, that the first and last module in the chain need to  be terminated with a 100 Ohm resistor. This should be enabled via the control panel. I configured a set of four modules just as described in the manual, but regardless of what I do, (changing the Master-assignment, switching order, etc.), the data acquisition in QuickDAQ doesn't work, it stays at 0 scans.

However, as soon as I switch off the terminal resistor for all of the modules, the data acquisition works just fine. 

So my question is, will this work just fine or am I risking errors in my data, or even worse damage to my modules, if I don't use the termination resistor as described? Or did I apply them in the wrong way?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hello @Christian Pichler.

Please confirm the wiring connections of all four DT9857E modules.  The image below is from page 110.  Only devices 1 and 4 have the termination option enabled in the Open Layers Control Panel applet.

image.png

 

Not setting the sync bus termination will not damage the modules.

Please reply with screen captures from the Control Panel and QuickDAQ settings.

 

Regards,

Fausto

Link to comment
Share on other sites

  • 0
Posted (edited)

Hello @Fausto,

thanks for your reply! Yes, I enabled the termination resistor only on the modules at the end of the chain, so on the master and on the last slave.

As you can see in the attached pictures, I've connected the modules just as described in the manuals, connecting the B/D sync terminals. The termination resistor was enabled at the bottom module (Master 1) and at the top module (Slave 4). 

As soon as I start acquiring data with the resistor switched on, QuickDAQ stays in "Idle" mode, shown in the acquisition status window. After stopping the measurement, the counter reads 0 scans. Furthermore, there is an error message at the bottom saying that the Index of the last module in the chain (Slave 4) was outside the bounds of the array.

If I switch the termination resistors off, the measurement runs just fine; it also writes the number of completed scans in the acquisition status window.

But there is something else: as soon as I use any other number of modules than 4, the measurement works with the termination resistor enabled. I've attached a picture of the measurement with module Slave 3 removed from the set. It is completely irrelevant, which modules I'm using, it works with the resistor on, as long as there are less then 4 modules connected. I've tested it with different setups using different modules each time, and it works just fine, so it's not a fault of a single module.

Thanks in advance!

Setup:

Setup 1.jpg

Setup 2.jpg

Settings:

Control Panel Master 1.png

Control Panel Slave 2.png

Control Panel Slave 3.png

Control Panel Slave 4.png

QuickDAQ Device Selection.png

QuickDAQ Input Channel Config.png

Measurement with termination resistors on:

Measurement Resistor on.png

Measurement Resistor on 2.png

After Measurement stopped Resistor on.png

Measurement with termination resistor off:

Measurement Resistor off.png

Measurement Resistor off 2.png

After Measurement stopped Resistor off.png

Measurement with 3 modules (Slave 3 removed), termination resistor on:
Measurement 3 Modules Resistor on.png

Edited by Christian Pichler
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...