Jump to content
  • 0

OM-USB-TC cannot see TC inputs in Labview




We have an USB-TC, bought from Omega labeled OM-USB-TC. Problem is I cannot see the analog or temperature inputs of the USB-TC in Labview with ULx. We also have a OM-USB-1608FS-PLUS connected.

PN : 193816F-03L

SN : 1CE3918

Instalcal config : DEV0 = USB-1608, DEV1 = USB-TC

Windows 11

Labview version 20.0.1f1 (64 bit)


I tested the USB-TC in instacal and I can see the temperature of a thermocouple in channel 0 (image 4). You can also see the USB-1608 and board numbers.


For AI Voltage, I can see the USB-1608 inputs only (image 1).


For AI Temperature, I see no inputs (image 2).


For Digital input, I see the inputs from both devices, USB-1608 and USB-TC (image 3).


I can read the digital data from the USB-TC, I ran the exemple ‘ULx Read Dig Chan’ and I see the input changing when I test it (image 5).



Thank you, 



Follow-up. I tried changing the USB connections to see if it had an impact and now it works! I don't understand why but this is what I did

1. Unplug the 1608 and connected the USB-TC in it's place. Relaunch Instacall and it removed the 1608.  Now I had the TC inputs in Labview in AI Temperature! 

2. Unplug the USB-TC and reconnected it where it was at first, when it did not show the inputs. Still working. 

3. Reconnected the 1608 where it was at first, so everything is like when I posted. Relaunch Instacall to add the 1608 back. Still works, strange. 

Edited by Slouper
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

The UL Create Channel VI can get confused if you connect a control to the physical channel input before selecting the channel type. I've seen this when channels are duplicated by copying voltage channels. You can copy the VI but not its inputs. Set the channel type to temperature and then connect a physical channel control. It's unclear if this is what happened, but it is something to keep in mind. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...