Jump to content
  • 0

MCC 134 library installation issues on Raspberry Pi OS and Ubuntu 20.04



Dear Community,

We recently acquired a DAQ card model MCC 134. The project we are working on needs this hat to work connected to an SBC ROCK PI 4C+ with an Ubuntu 2020 OS installed on it. When the install instructions are followed exactly as they are written, some error appears during the installation process and are not notified. In the following lines the error is described with some screenshots of the process (we also tried to install on a Raspberry PI 4 and it gives the same error).

When the GitHub repo is installed on the OS (step 6 of the documentation), during the execution of file install.sh (step 7) the installer notifies that file /lib/gpio.c can not be installed due to library bcm_host.h is not found anywhere on the OS file system. See attached picture.

We tried some solutions described on the following lines, but none of them have worked:

·        Reinstall the software as it is referenced by the documentation itself (note below step 7)

·        libraspberrypi-dev and raspberrypi-kernel-headers packages were not installed on our Rasperry OS distro. Did not work. References on 1, 2 and 3.

·        Include paths were modified and directly added. Did not work. References on 4, 5.

·        Scripts were reconfigured. Did not work. Reference on 6.

·        Firmware was manually installed revising all its dependencies and confirming their correct linking. Did not work. Reference on 7.

What is more, due to the impossibility to recognize I/O pins of the HAT, other firmware such as libdaqhats.so. are not installed. Would you kindly diagnose what could be the error and offer some type of solution to our problem?

Thank you very much in advance.


1) https://raspberrypi.stackexchange.com/questions/36121/fatal-error-bcm-host-h-no-such-file-or-directory-compilation-terminated

2) https://raspberrypi.stackexchange.com/questions/40503/failed-to-cross-compile-qt-5-6-on-rpi-2-fatal-error-bcm-host-h-no-such-file-o

3) https://forums.raspberrypi.com/viewtopic.php?f=91&t=154749

4) https://forum.qt.io/topic/62264/failed-to-cross-compile-qt-5-6-on-rpi-2-fatal-error-bcm_host-h-no-such-file-or-directory

5) https://stackoverflow.com/questions/14909615/raspberry-pi-bcm-host-include-directories

6) https://github.com/libretro/RetroArch/issues/9727

7) https://github.com/raspberrypi/firmware/blob/master/opt/vc/include/bcm_host.h


Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...