Jump to content
  • 0

MCC172 and RPi.GPIO package (Python)



Hello out there!

While doing my first steps with MCC172 and Raspberry Pi 4B I got an issue in combination with the GPIO usage. Every time I want to use a GPIO pin (t.ex. to light an LED) the MCC172 is not responding any longer. The only way to get back control is to reboot the RasPi. It has nothing to do with my LED or other peripherals, this even happens when I set up a GPIO pin without my breadboard connected to the GPIO.

I even tried a different package (gpiozero), but with the same result. Before addressing any GPIO everything runs as it should be. Are there restrictions in usage of the GPIO? Is there any interference/reciprocal effect with the MCC172? If so, which pin of the GPIO can I use for other purposes? I want to realize a switch/button that starts/stops my measuring routine, and a LED should indicate the condition (idle/busy). Could you give me aid/advice? Thanks a lot in advance!

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...