Jump to content
  • 0

Question with Library Installation - MCC128 on Raspi 3B+




Hoping to see if anyone could shed some light on what Im doing wrong or if there is a fix for it. Im currently going through the installation procedure for the MCC128 and when I get to the part were I run the install command (#7) I always get a warning from the gpio.c section stating the following (screenshot attached below as well):

gpio.c: In function 'gpio_init':
gpio.c:111:36: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
  111 |         printf("mmap failed %d\n", (int)gpio_map);
      |                                    ^

Installation still completes but afterwords when I run the DAQ Hat manager application the control app wont open. I can see the device and read the EEPROM. I have uninstalled and reinstalled the library but the issue persists. Just wondering if anyone has seen this problem before or if there are any recommended places to start checking for a fix. Id prefer not to go poking around in the code on my own but can if need be. 

Screenshot 2023-10-23 132040.png

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I run the 32-bit version of Buster on an RPi 3B+, and I don't get the GPIO warning. Try the following steps.

1. Could you uninstall the library and remove the daqhats folder, followed by a system update? 

sudo apt full-upgrade

sudo reboot

2. Could you make sure that SPI and I2C are enabled? You can do this using the Raspberry PI Configuration utility in Preferences - finally, reinstall daqhats.

git clone https://github.com/mccdaq/daqhats.git

cd ~/daqhats

sudo ./install.sh

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...