Jump to content
  • 0

DASYLab scan rate error




I am new to DASYLab and am currently trying to make changes to a preexisting worksheet. After I made a few edits and tried to run it, I received an error saying, "The scan rate/ and or block size are not the same for all of the module device3 inputs," with device3 being an external device. I have tried changing the ratio of block size to scan rate of the entire program under the measurement settings however, I am unsure of how to change the block size of each individual module. All I did was add another comparator and binary function and alter one formula. Seeing that the units of the inputs for the device seem to match, I am confused on what the problem could be/ what else to check. Any advice would be appreciated. 



Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

DASYLab is very picky about downstream modules receiving the same amount of data. You'll get the error if one device is set to 100 Hz and another to 200 Hz, and both are connected to a downstream module, like Write Data. It's a problematic error to diagnose when you're unfamiliar with the worksheet. I'd like you to please attach your modified version, and I'll have a look.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...