Jump to content
  • 0

BOOT.bin (Boot Image from SDK) Doesn't Work


sina_shiry

Question

Hi,

I'm trying to Booting My C++ Application from SD Card, I do the following actions:

1.start Vivado software.

2. New Project.

3. Select Zybo from Board lists.

4. Create Block Design.

5. Add Ip

6. Add Zynq7 Processing System.

7. Run Block Automation

8. Route M_AXI_GP0_ACLK pin to FCLK_CLK0 pin.

9. Validate Design (no error).

10. create wrapper

11. Generate Bit stream

12. Export> Export hardware (include bitstream).

13.launch SDK.

14. Create new application (c++).

15. Write my code

 

#include<stdio.h>
int main()
{
    while (true)
    {
        printf("sin\n\n");
    }
    return 0;
}

16. save

17. create new application

 

Name: FSBL

Os platform: Standalone

hardware platform: design_1_wrapper_hw_platform_0

Processor: ps7_cortex_a9_0

language: C

Board support package: create new

 

18. slelect "Zyng FSBL" template

19.Create Boot Image

20.select *.bif path.

21. add FSBL.elf as bootloader file

22. add design_1_wrapper.bit as data file

23. add Myapp.elf as data file

24.create BOOT.bin file

25. format SD card as FAT format mode.

26. copy BOOT.bin file into SD card

28. put SD card into Slot

29. change JP5 Jumper in SD mode

30. power on.

But only Red LED turn on, and green LED turn off for all time.

PLEASE HELP ME ABOUT THIS TOPIC

(Excuse me for my bad English)

 

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

Hello sina_shiry,

You followed the right steps but you'll have to open the console in order to see something. With the board connected go to SDK terminal on the bottom of the window (See picture below) and click on Add (+)

 Capture.JPG

A new window will open and you'll have to select the com your board is recognized as.

Capture1.JPG

After that, your messages sent on UART will be displayed. 

If it does not work, it is possible that your SD card has some problems, or the board itself. In order to exclude that, I attached below a bin file that is functional. Please put it on your SD and see if the board is functioning. It's a simple project that turns on and off your leds using the switches and when you press the buttons you'll see messages in the terminal like "button 0 pressed"

Capture2.JPG

If it does not work, please try with another SD card.

Let me know if this works for you then we'll check for further problems. 

 

Best regards,

Bianca

BOOT.bin

Link to comment
Share on other sites

Hi Bianca,

In the first, Thank you for your fast answer.

I used the BOOT.bin file that you posted, But this file don't work on ZYBO too.

In the other side, I used the BOOT.bin file that created by DIGILENT and it's for Image Filtering Demo (the link is below).

This BOOT.bin file works properly.

http://www.instructables.com/id/Quick-Start-Test-Demo-Zybo-Xlinx-Zynq-7000-Image-F/

My board Mode when used BOOT.bin file that you sent:

DSC_0005.JPG

 

when i used BOOT.bin file from the link (http://www.instructables.com/id/Quick-Start-Test-Demo-Zybo-Xlinx-Zynq-7000-Image-F/):

DSC_0006.JPG

Link to comment
Share on other sites

This is weird. I tested my bin file on multiple boards to see if I can see similar behavior. All boards behaved as expected. I will reattach here the bin directly from the SD card, if I may have sent you somehow the wrong bin. Please retry with this one. The fact that the board could be programmed with a bin file, suggests that the hardware is working. 

13702422_10206918538581650_388422302_o.jpg

Have you tried with another SD card?  

BOOT.bin

Link to comment
Share on other sites

Thank you very much.

The Problem was the SD card. I changed with another one, and BOOT.bin file work.

But I don't know why the DIGILENT BOOT.bin file works properly with bad SD card!!!

Finally, thanks for your attention.

Best Regards.

 

 

Link to comment
Share on other sites

It could be a problem with the FSBL file. In order to be sure that the FSBL is the problem you could use the debugger and see where the FSBL stops. It would be interesting to find out why does work on one SD and not on another. If you want to use the debugger you'll find information in the Xilinx documentation.

Best regards,

Bianca

Link to comment
Share on other sites

Hello, I have realized what was hapenning. I had forgotten to mark the SD option in the Zynq architecture configuration. Once I marked everything was working succesfully.

Anyway, thank you for your answer !

 

Best regards,

Raúl

Link to comment
Share on other sites

Hello, I am trying to do the same with a SD card, and either with your .bin file and the file from (http://www.instructables.com/id/Quick-Start-Test-Demo-Zybo-Xlinx-Zynq-7000-Image) the Zybo board is running perfectly. The problem is when I am using my own .bin file, that it has been generated using exactly the same steps as the first intervetion of sina_shiry

I don't know if maybe it should be necessary to use the WALL power source, but I think this is no the main problem. I am using Vivado 2016.4 and SDK.

I would be very gratefu if someone could help me. If you need more information about what I am doing, I can give it. 

 

Thanks in advance,

Raul

Link to comment
Share on other sites

Hi Raul,

Is your file named BOOT.bin? If yes, I'm not sure why you have issues. It might be something not generated correctly. If you are working in SDK in the Appendix A from the zed is shown how to create a boot image. https://reference.digilentinc.com/learn/programmable-logic/tutorials/zedboard-programming-guide/start?s[]=appendix 

Best regards,

Bianca

Link to comment
Share on other sites

Hello, I test the .bin of you and it works for me, but mine does not. You may be able to prove it because I am doing exactly the same things I see in your indications.

Also the Zybo I use does not let me program it by jtag, this is the error that gives me.

this link is the .bin because it is very large, I have also attached the error:

https://my.pcloud.com/publink/show?code=kZ9Rek7ZIt7TH3iEJ6j5AXKUzgdF8bDrX2w7

Thanks in advance

Robiert

 

 

Sin título.png

Link to comment
Share on other sites

Hi @Robiert Sepúlveda Torres,

I would check your USB A to Micro B cable and make sure that it is wired for data as well. One way to do this is if you able to see data from a compatible smartphone using this cable? What do you see in the device manager under ports and universal serial bus controllers when the zybo is connected? Do you have JP5 set correctly? 

thank you,

Jon

Link to comment
Share on other sites

Hi

He had already done this tests and the problems reappeared. A few months ago a colleague of mine tried to update the FTDI eeprom drivers and then the problem appeared.
I could solve by programming the designs for the sd card but my designs do not work. If you could try the image that I have attached you would be of great help to me.
Best regards.
Robiert

https://my.pcloud.com/publink/show?code=kZ9Rek7ZIt7TH3iEJ6j5AXKUzgdF8bDrX2w7

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...