Jump to content
  • 0

USB-2416 problem



On this product i am measuring type K thermocouple only. I am using a fluke 5522A to source thermocouple 

The first 4 channels i tried were all about 5 degrees Fahrenheit below what was expected to be produced.

Then i tried the ice bath method and still. about 4-5 F   below what was expected to be produced. 

The USB 2416 was then ran through the self cal mode and still produced non accurate readings similar to what was produced before the ice bath.

Even changed the settings for it to be reading in volts and not thermocouple and the exact millivoltage appeared to be coming in. 

What's weird is I took a fluke 754 and simulated the type K thermocouple to the USB instead of using the fluke 5522A and I got perfect readings. 


Any suggestions? Tried different thermocouple wire. Tried ice bath. Tried self cal. Still 5 degrees off in every reading but not when i use the fluke 754 to simulate? Very confused


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

When was the last time your two FLUKE calibrators calibrated?

One of them must be out of cal, no?

You can send in the UISB-2416 for calibration at our facility, it is NIST traceable.

I would need to start by knowing the serial number of the USB-2416 you want to sent in.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...