Jump to content
  • 0

Library Installation for MCC DAQ HAT for Raspberry Pi 4


Duc Anh Nguyen
 Share

Question

Hi,
I am trying to install the MCC DAQ HAT library for my raspberry Pi 4, however, I even though it said installed successfully, I saw that it had a fatal fail during reading DAQ HAT EEPROMS. The error is:
modprobe: FATAL: Module at24 not found in directory /lib/modules/5.15.0-1014-raspi Modprobe of at24 failed. Do an rpi-update.
I have tried to do an rpi-update and it has already been up to date, but when I try to run the installation again, the same error still occur. I followed the exact procedure provide on the gitHub link. Please help me with this issue. Thanks.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello @Duc Anh Nguyen

Click on the Raspberry Pi 4's Start icon, and then Preferences >> Raspberry Pi Configuration.

Click on the "Interfaces" tab, and enable SPI and I2C.

Reboot the system and try accessing your DAQHat from the MCC DAQ HAT Manager control panel.

If that still fails, then I will need to know:

What model(s) daqhat you have?

What version Raspberry Pi are you using?

What OS version are you using?  You can run “cat /etc/os-release” if you cannot remember.

Are you running the graphical version of the OS or terminal only?

Are any other applications running when they have the problem?

Do you have any other HATs attached to the RPi?

Thanks,

Jeff

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...