Jump to content
  • 0

DASYLab 2022 Lite not loading pscript module

S e a n


First, apologies if this isn't the correct place. If there's a better place to post this question, any direction is appreciated!

Second, I'm a beyond novice user. I'm mostly a web programmer but also a troubleshooter and yesterday I got handed a Thermes-USB device by PhysiTemp that our customer has an application for. We are using DASYLab 2022 Lite and I got the environment on the customer's PC from non-working to practically-working. But one problem remains. When I start up DASYLab, it gives me the error: "Cannot load module type pscript (Code -2)". After clicking "OK", it continues. I am able to open the Thermes-USB worksheet and everything looks pretty much normal to my untrained eye.

Obviously, it would be better not to have the pscript error. Our customer would see it every time they use the software and looks untidy. But more than that, I worry that errors due to the unloaded pscript module will pop up during practical use.

I've done the following troubleshooting:
I have installed InstaCal and a trial version of DASYLab on my own PC. After connecting the device, performing calibration, and enabling the Measurement Computing package, I am able to load DASYLab without issue. If it worked this way on my customer's PC, I'd probably not be here right now. So I think I understand the basics of the installation and configuration process.

On our customer's PC, after finding out that we have to enable support for older versions of .Net Framework, I was able to at least get basic functionality. But I keep running into the above pscript error wall. So I decided to try launching DASYLab by right-clicking and chosing "run as administrator." That also didn't work right, but it did provide me with a different error. It said that it was not able to find pmp_pscript. I found that file in the root directory of my C drive. I moved it into the DASYLab main directory and restarted DASYLab as administrator again. This time it gave me a message about a different missing file, which was also in my C drive root directory (spoiler: trying to run DASYLab as administrator is actually what generates the files in the C drive root directory).

By moving a total of six files, I was able to get DASYLab to open without the pscript error, but! Two problems:
1. It would only run without showing me the error, but the error saying that it couldn't load a component of pscript was still being displayed to the console.
2. Running as a regular user still generates the error message dialog box.
Also, the presenece of those files in the DASYLab directory seems to have some benefit to my customer's PC, but those files are not in the DASYLab directory on my own PC. I guess they're not actually supposed to be there.

Extra information: the account on both my own PC and on the customer's PC are administratory accounts, and the OS on both is Japanese Windows 10. I don't think the Japanese part matters as it is working fine on my own PC, but thought I would throw that out there.

Sorry for the novel, but if anyone has any suggestions, I'd appreciate the insight.


Edited by S e a n
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

This problem is solved, thank you for the message, @Jeffrey.

DASYLab may not be the focus of the group, but as it is software used by people here, I will explain the problem in the (admittedly unlikely) event someone encounters it.

The problem was Japanese-related, though not a product of the OS itself. The user's directory contained Japanese characters and as a result, DASYLab wasn't able to access the user's designated "temp" directory.
There are two ways to solve it, one is to redefine the temp directory, and the other is to create a new user using alphanumeric characters.
There is a third way, where you keep the username and only redefine the home directory, but I haven't tried this personally and don't want to risk our customer running into problems down the road because of an unusual configuration.
Not only Japanese, but I imagine any other language that uses encoding other than what DASYLab expects is susceptible to this problem.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...