Jump to content
  • 0

Problems with uldaq installation




I have followed the instructions to download, install and configure uldaq on my MacBook (Big Sur 11.6, Chip M1). The installation of the module seems fine, but when I run my program that imports uldaq:

import uldaq

I get this error:

OSError: dlopen(/usr/local/lib/libuldaq.dylib, 6): no suitable image found.  Did find:
        /usr/local/lib/libuldaq.dylib: mach-o, but wrong architecture
        /usr/local/lib/libuldaq.1.dylib: mach-o, but wrong architecture

Any advice would be appreciated!


Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hi John,

Yes, I get it with the example files. I have edited to iterate measurements in a way that is useful to my experiments (without touching the parts of code that take care of communication or setup of the device) and it does not work. I do not think that the problem is in the python files as much as in the installation of uldaq itself in my Mac, since if I run the same identical code in a different machine (Linux) where all of the system had been installed months ago, it works fine.

I am using a device USB-1608G Series High Speed Multifunction

Link to comment
Share on other sites

  • 0

Hello John,

This had given me problems in the past few days but I had been able to overcome the libusb issue, configure, and make it. 

I also ran the "pip install uldaq" command, and it did not give me errors... for some reason though, it seems like the version of uldaq that I am installing on my computer has the wrong architecture...

Link to comment
Share on other sites

  • 0

I have tried...

I get this error below. Is it possible that uldaq does not work with M1 chip and needs the Intel (x86_64 architecture?)

OSError: dlopen(/usr/local/lib/libuldaq.dylib, 0x0006): tried: '/usr/local/lib/libuldaq.dylib' (mach-o file, but is an incompatible architecture (have 'arm64', need 'x86_64')), '/usr/local/lib/libuldaq.1.dylib' (mach-o file, but is an incompatible architecture (have 'arm64', need 'x86_64'))
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...