Jump to content
  • 0

Arty A7 Board Vivado 2020.2 [Labtools 27-2269] No devices detected on target localhost:3121




I am using Arty A7 board connected with laptop using micro usb cable and Vivado 2020.2 version is used.

The fpga part no is mentioned as XC7A35t CSG324ABX1841.

The jumper JP1 is open. The power led is on.

When i run open hardware manager the localhost(1) status is connected.

In hardware target properties, name is displayed as localhost:3121/xilinx_tcf/Digilent/210319AB51BBA and status is open.
But Number of devices is displayed as 0.

In message window the following error message is displayed:

[Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Digilent/210319AB51BBA.
Check cable connectivity and that the target board is powered up then
use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

I request to guide me to overcome this. Thank you.
Best regards,


Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Hello @Subbu,

I have a few troubleshooting questions for you:

- What operating system are you using?
- If you are using Windows, can you see the board in the Windows device manager? It would be listed as USB Serial Converter A and USB Serial Converter B under the Universal Serial Bus controllers dropdown, both with which with bus reported device descriptions in the Details tab of their Properties window of "Digilent USB Device"
- Did you install the cable drivers?
- Are you able to detect the board if you use the Digilent Adept software?
- Has the board been successfully detected before previously?
- Have you attempted to connect the board with a different USB cable or to a different computer? (You do not need to have Vivado installed on a different computer, you can check in the Device Manager or with the Digilent Adept software).


Link to comment
Share on other sites

Hello JColvin,
Thank you for your reply.

Regarding your questions my answers are given below.

- The os is Windows10 home (version 20H2) (OS Build 19042.867).

- When the board is connected with USB micro B cable, device manager adds 
  USB Serial port(COM8), USB Serial Converter A and USB Serial Converter B.
  In Bus reported device description, Value is displayed as Digilent USB Device
  for both converters.

- Regarding cable drivers i run install_drivers in administrator mode
  and the results in install_drivers_wrapper.txt is attached.
  I like to know more details about this cable drivers 
  and their role in arty a7 board communication.

- While running Adept, in connect detail Arty is displayed. In Config window
  "No devices identified" message is displayed.

- After placing the jumper JP1, Using Tera Term VT setting the 
  com8 baud rate at 115200, after pressing the PROG button 
  Avnet/Digilent Arty Evaluation Board LEDs and switches GPIO Demonstration
  is running and communication details are displayed in terminal window.

- I tried with another cable which is used with Android phone for data transfer.
  but end up with same result. 

  I request your advice to correct this. Thank you.

  With regards,

Link to comment
Share on other sites

Hi @Subbu,

I apologize for the delay. I'll have to dig into this some more.

From what you posted, the Vivado Hardware Manager is sucessfully able to detect the board and it's serial number (210319AB51BBA) but apparently not able to connect to the downstream FPGA. Adept is seemingly reporting the same details. The cable drivers are what Vivado/Vitis uses (as does Adept; Vivado and Vitis use the same drivers) to communicate the FPGA device over USB.

I'm also surprised to see the board running its embedded flash demo at 115200 baud, since I thought most of those projects were instead running at 9600 baud. But if the demo is running, that would indicate to me that the FPGA itself is working. But apparently not able be detected/programmed? I'll have to look into this some more.


Link to comment
Share on other sites

Hi @Subbu,

I asked other engineers about this issue you are encountering and determined the board you have likely has some sort of issue with the JTAG connectivity, which is not easily fixed.

I would recommend contacting whomever you purchased the Arty A7 board from (probably Digilent directly or a distributor) to initiate an RMA. If you purchased the board from Digilent, I can give you some additional instructions in this process.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...