Jump to content

Cannot download and install Digilent Agent

Recommended Posts

I just bought an OpenScope MZ and I need help downloading the Digilent Agent. Here is the sequence I followed and problems I encountered:

1. followed the directions from the web site: https://reference.digilentinc.com/learn/instrumentation/tutorials/openscope-mz/getting-started

2. this site, gives a link for Windows. The link given was: https://resources.digilentinc.com/digilent-agent-v1-2-3-exe/?_ga=2.37294240.1471654216.1587263945-1669883515.1587263945

When I click this link, the browser "gives-up" with a page not found. 

3. Apparently the URL of step #2, was redirecting to another site; the new URL was: https://resources.digilentinc.com/digilent-agent-v1-2-3-exe/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/adfs/index.html

This tells me that it tries to authenticate from somewhere.

4. I went to GitHub and attempted to get a copy of the Agent from there: no luck -- not available.

I tried multiple things such as:

   A. clearing the cache of the Browser

  B. Using a different Browser (Chrome, Edge, Explorer)

  C. Using three different machines

  D. Moving to an iMAC

NOTHING WORKED. Can someone give me a copy of the Digilent Agent for Windows 10? A link? Anything?

By the way, I connected with the Serial Port at 1,250,000 baud; I was able to configure the WiFi. But the firmware needs to be updated which requires the Digilent Agent to be running. So frustrating...

Please help!

Link to comment
Share on other sites

Hi @GeoKon and @BrianF,

I have verified that the links are not working; I was hoping that it would be as simple as turning off the ad-blocker on my browser since that has been a problem in the past for me, but no luck on that front.

I have reached out to our web team to get this resolved since I presume it is a server side issue.

Thank you for your patience,

Link to comment
Share on other sites

Hi @GeoKon and @BrianF,

The server side got rolled back and we're looking into it but here are some links that I tested that should still work:




Let me know if you have any questions about this.


Link to comment
Share on other sites

Hi JColvin

You are great helping me and BrianF.

I was able to use the first link and download the Agent. I initially got a Windows 10 error "0x000012f" but the service started functioning. I was able to update the firmware and run the oscilloscope.

I am good for now. Million thanks for your help!!!


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...