Jump to content
  • 0

Hello and question regarding zynq and petalinux gpio..


Chrish
 Share

Question

Hi, I'm new to zynq processor and I tried to search this around but have not get a working solution..

I am playing with Arty Z7 20 which has a zynq and I'm able to build petalinux and connect through UART (which is provided by Digilent not me).

I'm able to see some AXI GPIO for LED/switches in /proc/device-tree but I'm not able to see them mentioned in dmesg nor /sys/class/gpio.

I do see part of them in /dev/uioX but when I tried to fread them it does not quite make sense.. Though the address info from /sys/class/uio/uioX/map/map0/addr seems legit..

Is there a straightforward guideline regarding how I should use these gpio/uios?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 1
On 1/3/2020 at 4:01 AM, juergenR said:

Have a look here, too:

https://forum.digilentinc.com/topic/16550-uio-access-including-interrupts-when-using-petalinux/

BTW, you are not locked to use the older tool chain; I am actually using 2019.1

Thanks!

I have then used petalinux 2019.1, since my Vivado is 2019.1 and the hardware design looks workable. 

Then I recreated petalinux project under 2019.1 using the generated HDF and bit stream, removed some un-used video IPs and now it works!

 

However I did not use the system-user.dtsi attached in the link. Actually I need not to use the modification somehow and can export the gpios. I have not started check interrupts/uio yet.

Edited by Chrish
Link to comment
Share on other sites

  • 0
53 minutes ago, jpeyron said:

 Hi @Chrish,

I moved this thread to a sub-section where more experienced embedded linux engineers look. Have you looked through the readme here for the Petalinux releases for the Arty-Z7-20.  The Linux GPIO Driver Xilinx WIKI might be helpful as well.

best regards,

Jon

 

Hi Jon, I went through the Digilent petalinux github, that's basically how I went this far ? I will try some more this weekend

Link to comment
Share on other sites

  • 0
On 7/25/2019 at 2:33 AM, tkoroknai said:

Hello @Chrish

Have you tried using the .bsp file?

https://reference.digilentinc.com/reference/software/petalinux/start

you can just use:

petalinux-create -t project -s Petalinux.bsp

then  copy BOOT.BIN and image.ub and boot from the sd card.

 

I think this way you should be able to see them in  /sys/class/gpio

 

Hi

I have not tried that yet. So far I have found that the hw part is good and if I use bare metal the software works as expected. After some familiarize I plan to create a new petalinux project and see if it works. Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...