Jump to content
  • 0

Cannot connect PYNQ-Z1 (Both Ethernet and USB Serial)



So I want to connect the PYNQ-Z1 board directly by opening a USB serial terminal. The PYNQ-Z1 board is bought with the pre-loaded image in the SD card. The board setup is the following:

- Connected with external power adapter

- Port J14 UART is connected to USB port on the laptop

I waited until the system is booted and ready to use, opened the PuTTy on laptop, set:

- Serial port: COM10 <--- I checked in the Windows Device Manager.

- Speed (baud rate) : 115200

- Data bits : 8

- Stop bits : 1

- Parity : None

- Control flow : None

But when I clicked open, nothing happened on the screen. Is there any required step before using the serial port on the PYNQ-Z1 board?



Link to comment
Share on other sites

8 answers to this question

Recommended Posts

I assume you use Windows.

In order to know which COM port to choose, please take a look in the Windows Device manager before and after you plug the USB cable. You should see something like this:


The standard Pynq image is communicating at 115200 baud rate, so if you use this image you should setup the terminal at this baud.

This is how my Terra Term looks after booting:


Good luck.

Link to comment
Share on other sites

The problem still persists. I have tried almost all the ways to connect directly with serial port:

- Rewrite the PYNQ-Z1 Image v2.3

- Try on both Ubuntu and Windows with Putty

I also noted the previous bug about COM10 port on Windows but still unable to connect with the workaround.

So I tried to assign static IP to my PC and connect to on the browser (with the Ethernet cable now connected directly from PYNQ-Z1 board to my PC). My PC has both Wifi and Ethernet interface. I am not sure if this is the problem. But what I did is, in Ubuntu 16.04 LTS, I turned off the Wifi connection and set the static IP as shown below. Even this I still cannot connect to on the Chrome Browser.

It is very weird.

Could anyone shed some light? I will get back if I solve the problem.


Link to comment
Share on other sites

On 1/16/2019 at 11:16 PM, vicentiu said:

We just tried with the image from our PYNQ reference page and it worked fine.

Did you try pressing the ENTER key once you opened the terminal to see if you get a prompt?

You don't need to wait until the system boots to open the terminal connection.

How do you know the system booted?

I check the sequence of LED light. I am quite sure the system has booted successfully. (But you are right that we don't have to wait until it has booted.) About the serial terminal, the PuTTy window just doesn't proceed when I clicked "Open".


After a minute you should see two Blue LD4 & LD5 LEDs and four Yellow/Green LD0-LD3 LEDs flash simultaneously. The Blue LD4-LD5 LEDs will then turn on and off while the Yellow/Green LD0-LD3 LEDs remain on. The system is now booted and ready for use.


Link to comment
Share on other sites



I would try 9600 Baud and use teraterm instead.


The problem seems to be the PuTTY. I just tried with Tera Term and it works.

Now the serial port works, but I cannot connect to the board with the Ethernet interface. I just want to use Jupyter Notebook so that I can run code from the browser.

Link to comment
Share on other sites

Can you give more detail on what you have tried to connect to Pynq? You did a direct connection between your computer and Pynq?

What does 'ifconfig' on Pynq look like? What does network interface setup look like on your computer? Can you ping in either direction?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...