Jump to content
  • 0

Get Internet on Zybo Busybox



Hello everybody,


I have been able to complete the "Embedded Linux Tutorial - Zybo" and boot Busybox from the Zybo with a few minor changes (see bottom of the post). I was not able to do the same for the Linaro Ubuntu as the system freezes after a while (more on this in this thread).


I don't care using Busybox instead of Linaro, even though its limitations. However I would like to configure Internet and I don't know how to do that. I was able to ping myself by doing: "ifconfig lo" followed by "ping". However I don't know how to communicate with the outside world, I alway get "network unreachable" error. Does anyone know how to do this?


PS: The changes I did to the tutorial were ->

  1. Use the arm_ramdisk from: http://www.wiki.xilinx.com/Build+and+Modify+a+Rootfs
  2. change the bootargs in the zynq-zybo.dts to " bootargs = "console=ttyPS0,115200 root=/dev/ram0 rw init=/sbin/init earlyprintk rootwait devtmps.mount=1" "
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Hello miguel,

I am not familiar with Busybox I bet it isn't any different than a standard linux networking.  Have you tried pinging your router or something on your network?  If you can ping a local network device then all you should have to do is set a nameserver in the /etc/resolv.conf file.  It should be something like this:  

"sudo nano /etc/resolve.conf"





then reboot or restarting the networking service should fix it.  

Best of luck!


Link to comment
Share on other sites

Hi there, I solved the problem. The cable was not correctly connected to the router (should have known since the ethernet leds were not blinking). To enable the internet, the sequence of commands is as follows:


  1. ifconfig eth0 YOUR_NEW_IP
  2. route add default gw ROUTER_IP eth0
  3. echo "nameserver ROUTER_IP" >/etc/resolv.conf
  4. ping google.com

where to find your ROUTER_IP you may do "route -n" in your host computer. It is the one marked with the UG flag, under Gateway. As an example:

  1. ifconfig eth0
  2. route add default gw eth0
  3. echo "nameserver" >/etc/resolv.conf
  4. ping google.com


Yes it was a dumb mistake lol

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...