Jump to content
  • 0

mpide under linux does not upload to uc32



I have 4 uc32 boards with AnalogShields. I have been programming one set using mpide under Windows 7 for several weeks. Yesterday I was in a classroom with a group of students busily working on a project with Linux (Ubuntu 64 bit) laptops and discovered that the mpide under Linux will not upload a compiled file,  such as the "blink" example, to the uc32 boards. The error message is "avrdude: stk500v2_ReceiveMessage(): timeout". I found a couple of threads on the chipKit forum reporting this error but no solution, other than using a Windows machine! The students have only next week to work on this final project for their summer course, for which I had bought these boards. Programs upload to the other uc32 boards just fine under Windows. The students' linux machines communicate with Arduinos using the Arduino IDE without any problem. I have tried 2 versions of mpide (20140821 and 20150204-test) and also uecide-0.8.7z36. All give the same error when trying to upload a program to the uc32. Under uecide, I also tried the alternative method of uploading to the board via pic32prog (instead of AVRDude), and earlier got the message "Board not found" but now am getting "Program flash failed. Resetting board. Upload failed." Is this a known problem with the mpide, linux, and uc32 boards? Do you have a solution? I suppose that I could put Windows onto a few of the students' laptops, or I could have them use Arduinos with the Analog Shield boards, but the extra memory and speed of the uc32 is very desirable for this application.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Hi SC3,

We attempted to replicate your issue with no success due to other issues. Unfortunately I don't think we can find a fix for the issue in a timely enough manner for the students to fix it, then finish their projects in only one week. However, we will keep looking for a solution.

Since your students only have one week to finish this project I would highly suggest that they save all their work, and install windows on their machines, or use another windows machine since MPIDE is such a quick download on Windows. I personally like having my computer dual booted with Windows and Linux, that way you have the best of both worlds. Here is a great tutorial on dual booting Windows and Ubuntu. Alternatively if the students don't want to dual boot they could install a virtual machine. There is tons of help online for both of these solutions.

Please let me know if you have any other questions, and best of luck to your students in their final week of semester.


Link to comment
Share on other sites

I had some problems uploading to my uC32 as well from Linux.  I can't recall if I had it working before this, but when I went to use it the other day I just couldn't upload to it.

The solution I came up with in the end was to re-flash the bootloader with the one from the PIC32-avrdude-bootloader repository (the same one that is included in the board definition for the beta version of UECIDE): https://raw.githubusercontent.com/chipKIT32/PIC32-avrdude-bootloader/master/BootloadersCurrent-hex/chipKIT-uC32.hex

As soon as I did that it started uploading perfectly fine.  If you're on the beta of UECIDE and you have a PICkit2™ handy, you can install the Bootloader plugin and re-flash the bootloader direct from inside UECIDE (in the Tools menu).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...