Jump to content

OpenScope Wifi re-connect doesn't work

Recommended Posts

I'm experience a similar problem. In my case I have to use the Digilent Agent to connect and manually setup wifi every time I power up the Open Scope (I get blinking blue light only); some times my network appears in the saved network list and other times it doesn't.

I'm on firmware 1.296.

Link to comment
Share on other sites

Hey Raj M,

I split this into another thread to make it easier to debug each issue.   For future reference the original thread is here.

  • When you use the Digilent Agent to setup the connection does it work every time (or nearly every time)?
  • Have you tried multiple networks?  If so do they all exhibit the same behavior?
  • Can you provide some details about the network:
    • Does it broadcast the SSID (ie is the network visible when you scan?)
    • What is the SSID (are there any special characters like spaces, etc)?
    • What encryption type does the network use?
  • How are you powering the OpenScope? 
  • Is there anything unique about your setup?
    • Lots of wifi noise, unique network setup, etc?




Link to comment
Share on other sites

Hi Kristoff!

  1. Yes, the reconnect works every time (I tried it maybe 20 times)
  2. I have tried 2 networks; A ubiquity AP and I've tried it once or with an apple airport
  3. The ssid is Z-2G and it uses WPA2
  4. The opensource is powered from a 12w usb powersupply (or off the port on my macbook); I've tried it with a usb power bank too.
  5. I don't think there's anything unique; the device is about 15' from the AP (clear line of site). We have probably 20 devices attached to our network (many of them embedded).
    1. The only unique thing is our 5g network is meshed but it's on it's own ssid.

Are there any startup logs we can look at?


Link to comment
Share on other sites

You should be able to get some additional debug info from the device through the USB UART connection.

  • Use WaveForms Live to setup your wifi connection.
  • Right click on the Digilent Agent and release the device.  This frees the COM port.
  • Use a serial terminal like PuTTY to open the serial port.  Set the buad rate to 1250000.
  • Press the reset button on the OpenScope MZ (the button farthest away from the wifi radio)
  • You should see boot up info printed to the terminal.
  • Here is what mine looks like when it connects to the 'Digilent_2.4G' network on boot.


You can use the terminal menu to do a lot of the same things you do from WaveForms Live but you should get more details in menu mode.  I suggest adding/removing/connecting to networks though menu mode to see if anything odd stands out there.


Link to comment
Share on other sites

I double checked the advanced settings when I did the wifi setup a few times and all the options were ticked.

When I'd restart the OpenScope (and it wasn't connecting to the wifi), click wifi setup and check the advance settings sometimes the Auto-Connect was unchecked (but the others were still checked).

Also, initially (maybe like the first few times I tried it) it would loose the name I'd set for it too.


Link to comment
Share on other sites

Changing firmware versions may cause previously saved wifi networks to stop working, but they should be cleared in this case.  As long as you're not updating firmware every time you boot (which it sounds like you're not) that shouldn't be the issue.


Link to comment
Share on other sites

Thanks Kristoff!

I couldn't get the serial console to work, I think there's an issue with OSX's screen command working with high bitrate devices.

However, the openscope did start connecting to our wifi on restarts. I didn't change anything about the network or the device it just started working...apparently I did something to make the pixies in there happy :)

Link to comment
Share on other sites

  • 1 year later...

Hi Kristoff.

I'm new here and with the OpenScope.

I'm having trouble with the WiFi configuration.

My AP SSID is hidden, so the OpenScope only detects and list all APs it can see and the MAC of my AP.

I have tried to configure it selecting the MAC on the list, and always ends on error.

Finally concluded that I must enable the Wireless SSID Broadcast, but this should be not necessary.

Other devices, like phones, IoT, consoles, ... sometimes needed to enable SSID broadcast at the first time only. After the initial configuration I returned again to hide the SSID and all goes well.

Only with the OpenScope I need to enable SSID broadcast for successfully configure and connect.

After that I tried to re-hide SSID again and the OpenScope can't connect.

It is a nightmare to change the AP configuration any time I need to use the OpenScope.

Any thoughts about this issue?


Other different issue:

The Digilent Agent offer an update to the WaveForms Live.

The newest update offered is v1.1.2, but the version of the WaveForms Live is 1.3.5

How can I get the current version?




Link to comment
Share on other sites

Hi @Josema,

I'm not certain if this is what you are experiencing in terms of connecting to the your SSID, but there are a couple of threads that discuss this here and here. The main thing (from my understanding) is that there is an issue where the OpenScope MZ will not connect to the network if the OpenScope MZ has been connected to the hotspot (or WiFi network) since it booted up, it'll receive a de-authorization signal; that first link has some (hopefully) better details on that.

As for the update, I believe the update you are seeing on the Digilent Agent is the offline WaveForms Live support which is different than WaveForms Live or the firmware loaded the OpenScope MZ (latest version of 1.301.0).

Let me know if you have any questions about this.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...