Jump to content

Using CMOD-a7's FTDI usb-uart


Recommended Posts


Has anyone tried using the CMOD-A7's USB to UART converter without Microblaze? I was able to see CMOD-A7 transmit to terminal using the "CMOD A7 Getting Started with Microblaze" tutorial. I want to do the same without using Microblaze. I tried driving the FPGA's assigned uart tx pin, using a previously working UART RTL, but the LED near USB connector does not even light up. Are there some other steps required or guidelines?



Link to comment
Share on other sites


I use the bench testing designs found here.  The hello world example would be worthwhile to start from.

The most common UART problems are:

  • Getting the TX and RX pins mixed up.  Within a schematic, both one of these pins will connect to two parts.  It's often not clear *which* part is TX and which is RX.
  • Getting the baud rate right.  Sometimes, you can see corrupt characters in your terminal if this is the problem.  (Sometimes)  Check the baud rate on both ends, and double check the clock rate on the CMod A7.
  • You can do a really quick/dirty test of clock rates using the LED (see here), just to confirm that the clock rate isn't the problem.  I've had troubles with the really fast clock rates before, so you might want to try something more reasonable--such as 115,200--and then make the transition to high speed (assuming you want high speed)
  • Another *really* common problem is hardware flow control.  Make sure you have it turned off for your first UART design--once you have that working, and you understand hardware flow control, then feel free to turn it back on again.
  • The USB cable doesn't support data due to a broken wire (this is more commonly a configuration problem than a UART problem)

Less common problems include not looking at the right UART port, or not having the right UART port in the first place due to an install issue.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...