Jump to content
  • 0

Compilation Error



Hi ,

         I have tried to find the fix for this and gone through some information over the internet but it was not solved  Please can someone respond to the below error why it occurs exactly


engineer@mcinhvendes14:~/lakshmi/Evalboard_code/u-boot-xlnx$ make ARCH=arm CROSS_COMPILE=arm-xilinx-linux-gnueabi-
make: arm-xilinx-linux-gnueabi-gcc: Command not found
/bin/sh: 1: arm-xilinx-linux-gnueabi-gcc: not found
dirname: missing operand
Try 'dirname --help' for more information.
scripts/kconfig/conf  --silentoldconfig Kconfig
  CHK     include/config.h
  GEN     include/autoconf.mk
/bin/sh: 1: arm-xilinx-linux-gnueabi-gcc: not found
make[1]: *** [include/autoconf.mk] Error 1
make: *** No rule to make target `include/config/auto.conf', needed by `include/config/uboot.release'.  Stop.


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

The error occurs either because you have not installed the arm-xilinx-linux-gnueabi tool chain, or (if you have) because you have not adjusted your path to reflect the installation.  The tools are available as part of the Xilinx Software Development Kit (SDK).

To know if your installation is set up right, try typing "which arm-xilinx-linux-gnueabi-cc".  If you just get an immediate next line, then you aren't there yet.  If on the other hand the which command returns with a path name, then go back and try your command above again.



Link to comment
Share on other sites

Am trying to load uboot(Xilinx) and bring the Zynq zc702 board up from sdcard. When i tried to connect to the board through the picocom command am able to enter till terminal ready after that i have not seen  any logs related to uboot and the terminal is getting stuck and searched over the internet for the solution but still am not sure why it's happening like this. Please can i get some info on this

 please can some one show me the connections of bringing up the board using digilent J-TAG cable because when i give the command "connect arm hw" am getting cable error in XMD console

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...