Jump to content
  • 0



Hi after connecting the thermocouple the unit says "an unknown error has occurred. The specified channel is invalid"

When tried through the Instacal test its says " Device not ready to send data. Please repeat operation" But the thermocouple connected at channel 2 shows value only once.  


Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello @Rakesh.

Please reference the following forum post for a description of errors -9000 and -9999.


In InstaCal, select only those channels with a connected thermocouple.  Use one thermocouple to test one channel at a time; select only the connected channel.  If InstaCal continues to report these error codes, then the USB-TC should be serviced.



Link to comment
Share on other sites

  • 0
Posted (edited)

Hello Fausto,

I did as you instructed, but in InstaCal, the first two channels reported the same code -9000, for the remaining six channels the connected thermocouple is working, the snapshot is attached.

When I tried to access this unit via DAQami, it did not respond. An error menu appeared "An unknown error has occured. The specified channel is invalid, the snapshot is attached.

In DAQami I have not enabled channels 0 and 1 which issued the code -9000



Edited by Rakesh
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...