Jump to content

Computer will Not Detect Cora Z7-07S SOC


Recommended Posts

My laptop will not detect the Cora Z7-07S. I have tried using different cables and ports on my laptop but the board does not appear in the device manager once connected. The power LED is on while the board is plugged in.

Link to comment
Share on other sites

Hi @Athesh,

When you say "device manager" are you referring to the Vivado Hardware Manager or the host computer's (presumably Windows) Device Manager?

If this is the host computer's device manager not detecting anything being connected when connecting to microUSB port on the Cora Z7, this means that the data connection portion of the USB connection to the host computer is not working. There are a few possible reasons for this:

  • The port on the host computer failed -- you have been testing multiple ports on your laptop, so this is unlikely, but I have had ports fail on my computer (and can also be a problem on hubs)
  • The USB/FTDI connection on the Cora Z7 has failed -- unlikely much like the computer host port failing, but technically possible to fail
  • The cable is not transporting data -- I know you have tried multiple cables but comparatively, this is the most likely, especially if it is marked as a charging only cable. You might be able to identify this by looking at the microUSB end of the cable to see if all 5 connections points are visible as this will be the biggest visual indicator.

If the Vivado device manager is not detecting the board but the host computer is detecting something when the Cora Z7 is plugged in, please let me know if the Bus reported device description of the USB Serial Converter is listed as a "Digilent USB Device":

Thanks,
JColvin

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...