Jump to content
  • 0

Troubleshooting MCC 152



I have an MCC152, that previously worked.  I ran an update yesterday.  SPI is still on, I2C is off,

Today I get the error "Can't Open MCC152".  The board is detected, and the eeprom can be read.  Is it toast, or is there something else I should check?

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hello @Donk.

Which Raspberry Pi module and OS are you using?

Do you have other HAT boards mounted on your RPi module?

When do you get that error message?  Please share a screen capture.

What type of update did you run?

Please run the MCC DAQ HAT Manager application from the main menu under Accessories.

Please share screen captures when you click on the List DevicesRead EEPROMs, and MCC 152 App buttons.

From the Terminal application, run the following and then retest your MCC 152.

sudo apt full-upgrade
sudo reboot

sudo daqhats_read_eeproms




Link to comment
Share on other sites

  • 0

pi@afspi02:~$ sudo daqhats_read_eeproms
Found EEPROM at address 0
Found EEPROM at address 1

pi@afspi02:~$ uname -a
Linux afspi02 6.1.21-v7+ #1642 SMP Mon Apr  3 17:20:52 BST 2023 armv7l GNU/Linux   
pi@afspi02:~$ cat /etc/debian_version

The open button on the MCC 152 window does nothing.  It does work for the MCC128.

When running my application I get the error code "Could not communicate with the device."




Link to comment
Share on other sites

  • 0

Thank you for the additional information. 

Please enable both the SPI and I2C interfaces in the Raspberry Pi Configuration window.

What are the outputs of the following commands?

cat /etc/os-release

cat /proc/cpuinfo | grep Model


When the MCC 152 worked prior to the update, was the MCC 128 already mounted on the RPi?


Link to comment
Share on other sites

  • 0

Good Morning,  As requested

$ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"


$ cat /proc/cpuinfo | grep Model
Model        : Raspberry Pi 3 Model B Plus Rev 1.3

Link to comment
Share on other sites

  • 0

Hello @Donk.

Thank you for your response.

Do you have other HAT boards mounted on your RPi module besides the MCC 152 and MCC 128?

Do you have another RPi module to test with the MCC 152?

Can you remove the MCC 128 and retest the MCC 152 HAT only?  (Run sudo daqhats_read_eeproms after the restart.)

Do you have the sales order/invoice of your MCC 152 purchase?

If purchased within a year, then you can get a warranty replacement.  Repairs are not available if purchased beyond a year ago.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...