Jump to content
  • 0

Pmod ESP32 Flash with Arduino Micro Error




I have a PMOD ESP32 I am trying to flash new firmware to. I have gone through the process of configuring and building the firmware, but when I attempt to flash I consistently get the following "A fatal error occurred: Failed to connect to ESP32: No serial data received".

My setup is as follows: I have a USB cable from my computer to an Arduino micro. GND and 3.3V pins on arduino go to the GND and VCC pins on J1 of the PMOD and arduino pins 11 and 12 (rx and tx) go to rx and tx on J2 of PMOD. I have SW1.2 set to ON. I have a simple arduino script running allowing data to pass through from serial to UART. I tested this connection with the original firmware, I got the OK reply after sending AT in Arduino IDE serial monitor.

I have tried all kinds of connections and settings. As far as I can tell my hardware is setup correctly, however it seems the PMOD is not in boot mode as the error states no serial data received. I have also tried pressing the reset button on the PMOD while it is flashing to no avail. I am using ESP-IDF in administrator mode on CMD.

I have also tried jumping IO0 and GND on J2, also connecting VCC and GND from arduino to IO0 and GND on J2 with no luck.

I have also ordered a PMOD UART to serial converter but I fear I will have the same results trying that when it arrives.

Any input is greatly appreciated.


Thank you

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I was able to successfully flash this board yesterday. below are the steps I took to get it to work.

I ended up using a HiLetGo Xbee USB to UART converter from amazon instead of the arduino micro as the bridge between my PC and the PMOD. This was helpful because it has LED's on the TX and RX line so I can see when data is being transmitted to and from. On the PMOD I had sw1 in the off position, and sw2 in the on position. I also jumped pins IO0 and GND, and used the RX and TX pins on the J2 connector. 

I plugged in the usb cable from the converter to my PC and opened a terminal window in PuTTY. When pressing the reset button on the PMOD I could see a message displayed in the window saying it was waiting for bootloader. At this point I closed the PuTTY window and then in ESP IDF used the python build.py flash command with no COM port defined so it runs through every COM port available. Success! it finally started to flash after 4 days of failed attempts. Note I did not need to press the reset button at all after I started the command in ESP-IDF.

I am not sure why the arduino was not working as the bridge, I am thinking it had something to do with the serial.read command in my arduino code, I don't think it was able to read from the PMOD when it was in Bootloader mode.

Another note to add, I did read in the detailed troubleshooting instructions from Espressif that the 3.3V input to the PMOD does need to be very stable and able to draw a certain current, some aftermarket boards are not set up to deliver enough power to the ESP chip causing flash to fail. even if the board is completely functional otherwise.


I attached a picture of my updated circuit for reference.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...