Jump to content
  • 0

Digital output doesn't work



I have an USB-TC device. I want to configure the DIO to turn on and turn off some components but when I tried whith the next LabVIEW code the device didn't change the state.

I tried the software DAQami for this purpose but nothing chaged. 

Do I need to change something on my code or update the firmware version? 

The version of LabVIEW is 2023 Q1 and the version of  Instacal is 6.74.

The firmware of the device is 1.20. 

Captura de pantalla 2023-07-31 145717.png

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello @g.martinez.

Please test the ULx example 'ULx Write Dig Chan.vi', which can be found in 'C:\Program Files\National Instruments\LabVIEW 2023\examples\ULx\Digital\Generate Values.llb' file. 

Connect a LED or DVM to a digital line 'DIO#' and 'GND'.  Run the example and toggle the digital bit.  Does the LED illuminate?

What components are you attempting to turn on?

The digital output lines only provide a couple of milliamps.  https://www.mccdaq.com/pdfs/manuals/USB-TC.pdf






I also created the attached VI example (for LabVIEW 2023) and I am able to toggle the LED on the digital bit 0 line.








Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...