Jump to content

[Solved] Runtime fails to setup in Docker

Recommended Posts

Hi all, I'm trying to install the digilent.adept.runtime package in a docker container for Raspberry Pi4.

Am running into this issue with the package's post-installation script subprocess failing and returning an error with exit status 1.  I'm using the balenalib/raspberrypi4-64-debian:buster-build as base.

I have ensured that the dependencies are apt installed (i.e. avahi-daemon libavahi-client3 libavahi-common3 libusb-1.0-0)

Can anyone help me?


Edited by toughpine
Link to comment
Share on other sites

  • toughpine changed the title to [Solved] Runtime fails to setup in Docker

Just wanted to share here, in case someone else faced the same issues as me. Realised that there is no need to use a Raspberry Pi 4 environment for Docker, within Raspberry Pi 4 itself. It is Docker, so swapped to Debian Buster, for arm-based system instead, and the problem is solved.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...