Jump to content

JTAG-HS3 Stimulus Signals Inactive During Autoconnect

Recommended Posts

Hello, I don't know if my HS3 dongle is damaged or not, but when I try to Autoconnect using the Hardware Manager in Vivado 2022.1 I don't see any activity on the TCK, TDO or TMS/TDI pins. Even if the FPGA were bad for whatever reason, I expect to see some activity coming out of the HS3 to stimulate these programming signals, but instead all I see is a solid +3.3V and no activity. 

In the Device Manager, the device shows up as a "Serial Converter" and appears to be normal. I see a message Warning me that 'JTAG cables cannot be supported' without dpcomm.dll. I think this might be part of the problem, but I don't know how to fix it.

Can anyone make a suggestion on how to this?

Thank you, Richard Vasquez


Link to comment
Share on other sites

  • 7 months later...


This issue might have a few different possible reasons. Here are some ideas to assist you solve the problem:

1. Make sure all connections are made physically: Verify again the connections between the target FPGA board and the HS3 dongle. Ensure that all required wires and connections are properly oriented and securely attached. Look for any disconnected or loose wires that might be the source of the lack of activity.

2. Make that the target FPGA board is receiving the proper power supply by checking the power source. Make sure the power supply is securely attached so it can feed the FPGA with reliable power. On the circuit board, look for any indications or LEDs that point to a correct power connection.

3. Verify the jumper settings: In order to allow JTAG programming, many FPGA boards have jumper settings that must be appropriately set up. Verify that any jumpers or switches related to JTAG are properly configured by consulting the documentation for your FPGA board.

4. Make sure you are using the most recent version of Vivado by updating it. For updates or patches that could fix compatibility issues with your hardware or dongle, see the Xilinx website.

5. Reinstall HS3 drivers: Consider reinstalling the HS3 dongle's drivers. Reinstall the drivers by uninstalling the old ones in Device Manager, unplugging the dongle, and going to the installer location for Vivado or the manufacturer's website. Reconnect the dongle after the drivers have been updated to determine whether the problem still exists.

6. Check dpcomm.dll: According to the warning message you stated regarding "JTAG cables cannot be supported" without dpcomm.dll, this library may be missing or improperly set. Verify that the Vivado installation directory contains dpcomm.dll. You might need to reinstall Vivado if it is missing, or you can get more help by contacting Xilinx support.

If none of these sources solves the problem, I advise contacting Xilinx support or the help channels offered by the HS3 dongle vendor. They ought to be able to offer more detailed instructions and support for debugging the issue with your HS3 dongle and JTAG programming setup.


Kind Regards

Vivek Garg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...