Jump to content

Openscope MZ reboots on connection attempt - can't connect

Recommended Posts


Following a failed firmware update. I'm unable to connect to my Openscope MZ (rev F) to go through the bootloader process of recovering the firmware.

The scope boots as normal and connect to wifi. I can also connect via serial and can see the terminal output in PuTTY etc. If I enter the IP address of the scope in the browser the scope detects the connection and redirects to waveformslive.com.

However as soon as I try to connect (either via agent or via network), the scope immediately reboots - LD5 flashes once, then LD6, LD5, LD6 in rapid succession and the scope reboots, and I get the error 'Unable to communicate with device' in waveformslive.

I've also tried connecting in bootloader mode, but still cannot connect. LD5 flashes once and once more after a pause - waveformslive informs "unable to connect with device".

With the scope connected via serial connection and with a terminal open, attempting to add via network the scope reports "New client detected" then "Option page detected" and the immediately reboots.

I've tried to connect using WIndows 10, 7 and OSX using different USB cables but with no success.

Terminal output on reboot is:

"OpenScope v1.296.0
Written by: Keith Vogel, Digilent Inc.
Copyright 2016 Digilent Inc.

File Systems Initialized
MRF24 Info -- DeviceType: 0x2 Rom Version: 0x31 Patch Version: 0xC

USB+:     4839793uV
VCC  3.3: 3303600uV
VRef 3.0: 2998535uV
VRef 1.5: 1500732uV
USB-:    -4788068uV

Using calibration from: flash
Found parameter for AP: xxx
Connected to AP: xxx
Starting Web Server

Enter the number of the operation you would like to do:
1. Enter JSON mode
2. Calibrate the instruments
3. Save the current calibration values
4. Manage your WiFi connections
5. View all files names on the SD card
6. View all files names in flash
7. Set the Oscilloscope input gain

Is Linked to the physical network
Link status: 0x0
Network Initialized

My IP:
Gateway IP:
Subnet mask:
Dns0: IP:
Dns1: IP:
Dns2: IP:
Dns3: IP:
My MAC: 00:1E:C0:3B:58:88

10 Sockets Listening on IP:"

Any assistance or suggestions appreciated.




Link to comment
Share on other sites

Hi @frokostfredag,

I have asked another engineer more familiar with the OpenScope MZ to take a look at this.

An initial question that I have is was this the first time you were using the OpenScope MZ or the first time that you were attempting a firmware update?


Link to comment
Share on other sites

Hi @frokostfredag,

That's some odd behavior that you're describing there. There is one thing I'd like you to try to debug this, and that's to enable the console output in WaveForms Live before trying to connect to the device. I'm hoping that this lets us see what command is causing the OpenScope to choke. You can do this by going into the Settings page, opening the Advanced section and clicking on Change Console Log. Set this to Console, then open the developer tools for your browser. For Chrome and Firefox this is Ctrl+Shft+i. The commands and their responses, plus some other additional information will be printed in the console here as you use WaveForms Live to configure the OpenScope. 

I would appreciate it if you could share the results with me, and together we will get to the bottom of this. 

Link to comment
Share on other sites

Hi @frokostfredag,

I got to talk with AndrewHolzer a bit more and learned that the firmware on the OpenScope MZ is corrupted and it would need to be re-flashed via the JP2 header. If you happen to have something like a chipKIT PGM or PICkit3, we can provide you with further instructions on restoring the device, otherwise I have sent you a PM with some further instructions.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...