Jump to content

No UART communication on ZyBO Z7


Recommended Posts

Hello to everyone,

Some months ago I bought a ZyBO Z7 board to start making experience with Vivado and Xilinx FPGAs.

I have followed the getting started tutorials, and developed the example using the on oboard switches and leds.

I am able to program the fpga and the example works almost fine. I have tried to use putty to test the serial communications and see some output messages.

I have configured putty to use a baud rate of 115200, with a parity bit and 1 byte lenghts for the messages. When I open the terminal I see no data at all.

I have tried different baud rates but it seems to me that the UART is not programmed correctly, it might depent from the configuration of the PL.

How can I debug this? I think that when the board was brand new, the serial connection was working correctly, since I could see the messages of the linux OS installed on the SD Card.

I have also seen that the PROGB led is always off.

How can I debug this? Is there a way to put the board back to a stable state (something like a factory reset) ?


Thanks to everybody for your advices,


Link to comment
Share on other sites

Hi @8Strings82,

There isn't a factory reset for SoCs, but there are known working example projects on the Zybo Z7 Resource Center, https://reference.digilentinc.com/reference/programmable-logic/zybo-z7/start. The UART is only controlled from the PS, so the PL will not readily affect it. Our Getting Started with Vivado IP Integrator guide goes through setting up a Zynq Processor and getting UART running through Xilinx SDK may be a good resource for you as well.

By PROGB LED, do you mean the Done LED? PROGB is a button.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...