Jump to content

OpenScope MZ Error Uploading Firmware

Recommended Posts


I recently got a new OpenScope MZ, and hooked it up to my MacBook (OSX High Sierra).

The Digilent Agent seems to work fine and connects to the board, and reports firmware version (0.185.0) when I open up WaveForms Live. (in Safari 12.0.3).

The first thing it wants to do is update firmware, but after it shows the Updating Firmware popup for a while, it seems to time out and shows "Error Uploading Firmware".

The board shows LED LD2 orange and steady, with LED LD1 quickly flashing red for the whole process.

I searched for other posts on this topic, but that didn't solve the problem. As suggested in one of the posts, I tried pre-downloading the firmware = same result, and as it is reporting the current firmware version apparently that means the current firmware is not corrupted. The post in question ended at that point, and thus my new post here :)

I've tried updating to an older firmware version first, but that also failed.
Then I thought maybe it required the SD card to store the firmware, so I bought a few 32GB ones, formatted to FAT32, and plugged that in. but no difference.
Edit: Just tried on Google Chrome, but that made no difference.

I'll add the firmware update screenshots too.

Has anyone else run into this, and is there a solution or workaround?





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...