Jump to content
  • 0

Problem running binary files




I'm working on the zybo z7-20 board and followed the Zybo Z7-20 Petalinux BSP Project guide on github to run linux on the zybo. All seems well however I had some apps that I needed to add to the rootfs to run. I am working with a touch screen and the two apps I used for that were evtest and tslib. after adding evtest to the rootfs it executes just fine but the tslib binary files will not and the output for them is: "sh: usr/bin/ts_test: No such file or directory". I recently did the same thing on the zynq zc702 board from xilinx and it all worked fine. i'm using the same  binary files that were cross compiled for the zc702 board since its the same chip on the zc702 and the zybo. Im also working with QT to develop a UI and when i upload the qt binary to run on the zybo I get the same error that says "no such file or directory" when the file is actually there. when i run the ldd command on the files I am trying to execute it gives me "not a dynamic executable" message. I am not sure what is going on and why the binary files wont execute and is giving me the error messages. 

thanks for your time

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

It's hard to tell why the files aren't being added without seeing your exact setup (recipes, config files, etc). One of the causes for  "not a dynamic executable" is some missing libraries, but there could be other causes.

I saw you also posted on Xilinx's forum. The fact that it works in 2015 but not in 2017 indicates some changes were made in how Petalinux deals with adding components.

Have you checked the differences in the user guides between 2015.4 and 2017.4? Check the sections about adding components and Appendix G: Obsolete Features.

Other than that, Xinlinx devs can comment better on why it wouldn't work in 2017.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...