Jump to content

Was working OpenScope, Now no Wifi

Recommended Posts


Was one of the original boards on the Kickstarter back then and until today the OpenScope has been great to work with.  I had some issues in the last year that I was unable to use the device as I was and today broke open my case and plugged in the Openscope.  I was able to use the Digilent Agent to connect to Waveforms Live and connect to the OpenScope board.  I see I was several revisions behind on firmware and updated to the latest it showed (1.301.0) which downloaded the Hex and flashed the device.  So far, no issues.

I then noticed it wasn't connected to Wifi and figured maybe the firmware update blew away my config that had been working.  Not true.  The old connection was there but not able to connect.

I then removed the existing config, rebooted the board, and came back to Setup Wifi options.  Here, I searched for SSID's and found the same SSID as previously saved, entered password for the WPA2 encryption, and connect.  Few LED's blink RED while it tries but unable to connect.  Error displayed was 'Error setting Wifi Parameters' as seen in the image below.

Odd as nothing has changed on the wifi side (It's my home Wifi and I control it and make sure it runs well) and yet it's not connecting.  Going down several revisions on the firmware, with full power off/on cycles, doesn't seem to help either.  Stuck on this setup.

Ideas, Hints?  Thanks!



Link to comment
Share on other sites

OK, bit more investigation and connected to the COM port via Putty.

Reset gives me the normal stuff and I see it's trying to make a connection to Wifi from a previously saved session.  Thing is, I deleted this in WaveformsLive but seems it didn't really do it.

Subsequent reboots shows the same actions.  While in UART connection, I am able to navigate the menus and when I go into the wifi setup, display existing connections; it shows nothing to delete yet it still maintains there is something there to auto-connect.  Showing files in FLASH does show a parameter file with my SSID that it seems it's trying to use but the Wifi setup won't remove it nor will the commands in the Putty session.

Added images showing (hopefully they display in order):

  Bootup showing it attempting to connect to previously saved Wifi but failing (even though I ask it to remove the previous settings/parameters)

  Image showing the list of previously saved wifi connections (which shows none) but having nothing to show or delete yet still trying to connect

  Image showing that in the FLASH, there are parameter files there which is what it must be using to try and connect.

Was there some major change in the naming of the config files in recent firmware updates that caused the old ones to remain, even when asked to be removed, yet not being able to alter the files for a new connection? 







Link to comment
Share on other sites

OK, went in UART and removed the existing Wifi files using the JSON mode.

Upon reset, it now doesn't make an attempt at connecting to Wifi and while it still detects the proper Wifi on a scan; I'm unable to connect.

Trying both JSON setup of the wifi or WaveFormsLive software fail connection and a residual file is left behind thus making each subsequent reboot attempt to connect to the Wifi that failed previously.  Have not found a total reset of the device in the JSON API calls but have tried my best to wipe, re-setup, whatnot and get it to connect wifi.

Hoping there is a command or method to getting this back on wifi as I use it remotely at my workbench using the wifi and a laptop on desk. 


Thanks Digilent and anything I can do to help debug this further; please let me know!

Cheers! (if you can't figure it out I like trying to solve problems, lmao!)

Link to comment
Share on other sites

Hi Ictinike,

I do not have a solution for your problem but maybe I can help you finding one.

The Errorcode you received in the first image of your second post shows 0x90403F0F. This is a compound WIFI connection error (0x90400000), so the interesting bits are 0x03F0F.

Digging through the MRF24G universial driver headers makes me believe that you receive a deauthentication frame from your AP. Maybe looking into the log of your AP can help you at least to find a reason for that.


The Error you receive in your latest post indicates that there are no WIFI networks found.




Link to comment
Share on other sites

Hi @Ictinike,

Have you resolved your issue, or found anything new? You mentioned this issue began when you updated the firmware; have you tried rolling back to a previous version and seeing if things work properly? If you are still having issues, I can help you troubleshoot and find the real issue at cause here.


Link to comment
Share on other sites

@AndrewHolzer @Fa-b @JColvin

Greetings!  I got some time just now to document what I have been doing and experiencing.  I'm sorry this is a long and image 'rich' post but hope it can shine a light on the steps I have been attempting as well, possibly; the steps I have NOT taken or done properly!

First, I have updated the firmware to the latest, downgraded to lower revisions, as well going back to sub 1.x versions in these steps.  It seems no matter the firmware version, the same situation occurs.  So let's start at the beginning.  I have a formatted, pre-existing SD card in the slot that was previously used to save both calibration and configuration of the board and wifi.  Board is an original Kickstarter board I received some time ago.  Last successful connection was, I'm guessing, 4 to 6 months ago.

I update firmware and confirm there are no wifi networks attached, scanned, or saved.  I updated to the highest firmware in the list which was 1.3 01.0 at the time of this post.  Oddly enough, there does show a 1.4x but seems it may be a wrong revision number or something because flashing the 1.4x hex; it reboots and tells me I need to update the firmware.  This, I feel, is another issue aside from the connection issues.


Upon going into WFL Wifi Setup, I am presented with all available scanned wifi ap's when I hit the 'refresh' button as well nothing in the Saved area.  To double check, I hit refresh at least 3-4 times on each.  No saved and scanned wifi ap's come back as expected. (I'm tired of blanking names (lmao) so from this point forward the wifi I wish to connect is named BERGLAN which is a 2.4 band, WPA2, with a very simple password I just changed for these tests.)


Clicking on the BERGLAN option I am presented with the parameters popup and enter the proper password.  Advanced Options are not modified and default.


Hitting the 'OK' button, I wait and end up getting the error below; 'Error setting wifi parameters'.


Going back to the main menu, then back into Setup wifi, I refresh and again see all wifi ap's listed on the scan and refreshing the saved wifi I see the one I attempted.  Modifying, removing, or adding anew this connection fails every time with the same error; 'Error setting wifi parameters'


Now, since it seems I cannot get connected; let us try via the UART and I disconnect the Digilent Agent connection to (in this case COM12) and connect Putty to the serial and reset the device via the pushbutton on the board.  I am given this first status upon reboot and shows that it is trying to use the previously saved connection details from WFL; but ultimately fails on the connection with error hex: 0x90403F0F


If I enter menu 4, 'Manage your wifi connection' and then menu 3, 'view saved wifi connections'; I see no results; no BERGLAN, nothing


At this point, I back out to Main menu and display files in both 'flash' and 'sd0'.  I am presented with a list of previous calibration files on 'sd0' as well additional calibration files AND what looks like a wifi param file matching the SSIDI was trying, named 'WFPARM_(mac ID)_BERGLAN.  This tells me, and confirms the bootup attempt at connection; that there are indeed saved connections in flash but going back to prior attempts to connect, both with WFL interface or the UART, it wants to work but is not.


I then go back into menu 4, 'manage your wifi connections' option and do a scan.  I indeed, just like in WFL, see all available ap's and the intended one wishing to connect.


From here, choosing to make a connection to Index 2 of the scanned ap's, the board sits and never returns.  I have let this scan sit now 20+ minutes without return.  The only way I can continue is to push the reset button on board, wherein we start all over again.


Again it attempts and fails the saved wifi connection.  I then enter JSON mode and delete the saved connection and enter back into menu mode to view if the file has been removed.  It has been deleted properly.



To ensure the file is removed, I reboot the board with the pushbutton again and find it attempts a wifi connection, even though we should not have any persisted connections, and errors out with error hex: 0xA000001B


I have even attempted in JSON mode to create a manual connection, to rule out a possibility of a save issue on the param files or something of that nature by going into JSON mode and entering the following (password simplified even more).  


I allow this to wait several minutes and then enter back into Menu Mode.


I re-check if there are files on the flash for wifi and there no files.  I also check sd0 since I do have the sd card inserted.  No wifi param files and only the pre-existing calibration/configuration files listed prior.


At this point, I cannot seem to make a connection; either via WFL or UART/JSON mode.  I am able to remove files using JSON but unable to create a manual using the same.  I can see my wifi listed in scans but all attempts to connect both ways fails.  I have tried this via latest firmware or earlier.  Nothing has changed on my wifi since the last connection that worked some months ago (I manage the ap).  The wifi firmware is DD-WRT, a custom firmware with options that I prefer and is run on a Netgear Nighthawk R7000 router.  All other things are the same and I am confused by this as it was working from the original reception of my Kickstarter board until several months ago (unsure of total time passed since last use but guessing 4-6 months)

I do have several other wifi ap's running off of the same 2.4ghz band that is hidden.  One is a guest network vlan'ed to exclude the local LAN and opting for a direct tie to the outward internet and another legacy ap, running WEP, for some of the older devices my children use without the ability for WPA2.

Sorry, that this post was long and in-depth but wanted to document the process I have been taking.  Reading on the forums, I have seen others have similar issues and I have tried the resolutions/methods contained within.  None seem to work and fit this condition my board is in currently.

It may be something very trivial I'm overlooking and being an engineer/developer myself, I tend to over analyze everything (lmao!) but I've tried to revert to the KISS Method (Keep It Simple Stupid) without success.  Hope this extra detail might help and I if something comes up that you would like me to try, attempt, or otherwise hack away; let me know!



Link to comment
Share on other sites

Just got it to work.  On a whim I updated my router firmware and it connected properly.

What's very odd is this is the same firmware that I had been running (I had a family medical issue) for about 8 months now and worked prior.  Unsure but hoping this holds.

Will update if issues arise but for now it's working again.  May flash back the old firmware and see if the issue comes back.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...