• 1

How to restore FT2232 EEPROM back to factory settings?



Hi Everyone,

Just accidentally flashed the EEPROM attached to the FT2232 device on the Arty. The board is dead without the USB connection. Been using for 2 months without issues until today.

In Vivado it is showing:

 "ERROR: [Labtoolstcl 44-469] There is no current hw_target.". 

when trying to Auto Connect with the target in Hardware Manager.

Within FT_Prog (FTDI's flash tool), the registers (e.g. serial number, vendor ID, D2XX/VCP driver ...) can all be read and modified. How can it be restored back to Digilent factory setting? Is there an FT_Prog template that we can use?



Link to comment
Share on other sites

Recommended Posts

  • 0

Hello @JColvin,

I am having the same issue as rest of the users here. I accidentally erased the EEPROM on my "JTGA-HS2 Rev A". I have another one that works fine. I tried saving its template using FTDI's FT_Prog, but that didnt seem to work. There is a significant difference between how FT_Prog reads these two devices. Hence, Vivado no longer recognizes my "JTAG-HS2 Rev A".

After reading above comments, I tried using Digilent's Adept, but that didnt recognize it either.

Thanks in advance,



Link to comment
Share on other sites

  • 0


luckily I found this post here. I have the same problem as most people here.
I wasn't giving attention and accidently erased the EEPROM on my JTAG-SMT3-NC through FT_PROG. It seems there is a way to restore it.

Please can someone assist me with restoring the EEPROM?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now