Jump to content
  • 0

Logic Analyzer Not Triggering?



Hey all, having issues getting the logic analyzer to work. I'm trying to observe a 3.3V I2C bus, but as far as I can tell the logic analyzer/digital input never trigger. In fact, it appears that the digital input always reads LOW, which is the opposite of what I would expect for I2C. When I probe the digital input, I can see that there is in fact a clock signal.

Any hints for what I am doing wrong? I've tried many trigger configurations, and none of them have worked. I'm not even sure it is a trigger issue, because again, it looks like the clock is being read as LOW when I'd expect it to be HIGH by default.



Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Sorry for the slow response, it turned out to be a faulty connection. Somehow the pigtails were fully seated on the BNC adapter, but there was no continuity between the digital pigtail wire and the bnc adapter. Reseating it made it work 🤷‍♂️

Thanks for the suggestions, it did push us to recheck!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...