Jump to content
  • 0

ipv6 address showing up but not ipv4 (Eclypse-Z7 Linux Demo)



I am following the ZMOD ADC Linux demo on the Eclypse Z7 resources page(https://digilent.com/reference/programmable-logic/eclypse-z7/demos/zmod-scope). 

I am using Ubuntu 18.04 on my host machine and SDK 19.1 as per the instructions in the demo. 

I am using putty to connect to my board over ttyUSB1 in PROG and an ethernet cable between the board and my host machine. The ethernet cable labeled eth0 is showing up on both my board and my host machine when calling 'ip a'

For step 6, when calling 'ip a' in putty, only the ipv6/inet6 address corresponding to eth0 shows up, and not inet/ipv4. I am required to use only ipv4 as per the instructions in the demo. 


I have tried modifying the /etc/network/interfaces file on my host machine and my board, using the ipv6 address in place of the ipv4 address, rebooting the host machine and board separately, removing and reestablishing eth0 with 'sudo dhclient -r eth0' and 'sudo dhclient eth0', resorting to other documented solutions to similar problems on google, and so far nothing has worked. 

attached are screenshots of my host machine's interfaces file, the output of 'ip a' on the board, and the output of 'ip a' on my host machine. 

I am not sure how to resolve this issue, any help would be greatly appreciated. 




Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...