Jump to content
  • 0

Does Pmod ESP32 support WPA2 Enterprise


BMS
 Share

Question

Hi. We are trying to hook up a Digilent Pmod ESP32 ESP-WROOM-32 WiFi Module to our customers network, a hospital with WPA2 Enterprise Wifi access. The AP is hidden, we have an SSID, a user and a password.

We tried the AT+CWJEAP command, but always get a (CRC) error. Even simply questioning the command results in the same error. While connecting to a 'normal' AP works immediately, and questioning the AT+CWJAP? works just fine.

image.png.a0fd871b4db54145e02358a2a35e0974.png

Can you confirm if the Pmod supports WPA2 Enterprise, what are we missing here? Thanks - Bart

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @BMS,

I am not aware of any reason why the ESP32 would not be able to connect to an Enterprise network. The command you are attempting should be correct; I am not at the local office this week to be able to test connecting to the Enterprise network that is there (I usually only attempted to connect to a local hotspot provided by my mobile device), though the error code is confusing since it does not match the format listed in the Espressif document here: https://docs.espressif.com/projects/esp-at/en/latest/esp32/AT_Command_Set/Wi-Fi_AT_Commands.html#id93.

One thing I would end up checking is that if the network you are connecting to advertises on a 2.4 GHz band since I believe the ESP32 device only operates on 2.4 GHz and not 5 GHz.

Otherwise I presume you are providing the correct parameters such as the method and identity as outlined in the same document (https://docs.espressif.com/projects/esp-at/en/latest/esp32/AT_Command_Set/Wi-Fi_AT_Commands.html#id92).

Thanks,
JColvin

Link to comment
Share on other sites

  • 0

Hi JColvin - thanks for your reply. 

The Wifi network is on 2.4GHZ, with a hidden SSID.

We are following the instruction for AT+CWJEAP=<ssid>,<method>,<identity>,<username>,<password>,<security>[,<jeap_timeout>]

and sending the following command (PASSWORD replaces the actual strong pwd): 

AT+CWJEAP="CHRH_WIFI",1,"equinox","equinox","PASSWORD",

We immediately get this strange/undocumented error 0x0109000 which is not found under Wi-Fi AT Commands - ESP32 - — ESP-AT User Guide latest documentation (espressif.com)

Could you perhaps test on your local office enterprise WPA2? I only have it available at the customer.. 

 

Many thanks. Bart

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...