Jump to content
  • 0

Basys3 won't connect



Hi, I could use some help. I installed Vivado 2020.2 and followed a video to create a small project.  When I opened the hardware manager it was unable to see my new BASYS 3 board.  The server was indicated to be running, but it could not find my board.  I looked in my computer's device manager (Its Windows 10) under USB serial bus controllers.  USB serial converter A and B is not present, there is no change to the list when I turn the board on or off.  I tried a second USB micro cable, the red power light is on.  The yellow led blinks once when the board is turned on.  I put the programming jumper to the middle (JTAG) position.  What should I check next?

Thank you,


P.S.  I plugged the Basys3 into my wife's windows 10 laptop, which does not have Vivado installed, it also did not show USB converter A and B.  There was no change in the device manager USB list when the board was turned on or off.




Edited by RobA
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Well, I have 2 bad old cables.  I purchased a new cable today and when I plugged in the BASYS3 I heard a little chime from the computer. 

Vivado now connects to my BASYS3 board.

I just downloaded my first file into the board and it works!!  

Link to comment
Share on other sites

  • 0

I'm glad to hear you got it resolved! I apparently didn't actually click the post button like I thought I had yesterday on this thread since it had looked like you tried everything that I would have normally recommended.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...